Opened 5 years ago

Closed 4 years ago

#1534 closed defect (fixed)

p.router.transport.ntcp.Reader: Error in the ntcp reader

Reported by: xmz Owned by: zzz
Priority: minor Milestone: 0.9.20
Component: router/transport Version: 0.9.19
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Hello,

Just reporting a critical error that my router experienced recently.

4/15/15 8:26:30 AM CRIT [P reader 2/4] p.router.transport.ntcp.Reader: Error in the ntcp reader
     java.lang.IllegalStateException: FailedEstablishStatereceived unexpected data on null
     at net.i2p.router.transport.ntcp.EstablishState.receive(EstablishState.java:216)
     at net.i2p.router.transport.ntcp.Reader.processRead(Reader.java:156)
     at net.i2p.router.transport.ntcp.Reader.access$400(Reader.java:21)
     at net.i2p.router.transport.ntcp.Reader$Runner.run(Reader.java:118)
     at java.lang.Thread.run(Thread.java:745)
     at net.i2p.util.I2PThread.run(I2PThread.java:84)

If you need more information, let me know.

Thanks,
xmz

Subtickets

Change History (5)

comment:1 Changed 5 years ago by xmz

Silly me, I forgot the additional information:

I2P version: 0.9.19-0
Java version: Oracle Corporation 1.7.0_76 (OpenJDK Runtime Environment 1.7.0_76-b13)
Wrapper version: 3.5.20
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
Platform: FreeBSD amd64 10.1-RELEASE-p6
Processor: Sandy Bridge H/M (corei)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: UTF-8
Charset: UTF-8

comment:2 Changed 5 years ago by zzz

Component: unspecifiedrouter/transport
Owner: set to zzz

never seen before

comment:3 Changed 4 years ago by killyourtv

I've also seen this on my Pi:

I2P version: 0.9.19-0
Java version: Oracle Corporation 1.7.0_40 (Java(TM) SE Runtime Environment 1.7.0_40-b43)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux arm 3.18.7+
Processor: uninitialized (arm)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: UTF-8
Charset: UTF-8
    18/04/15 21:11:45 CRIT [P reader 1/4] p.router.transport.ntcp.Reader: Error in the ntcp reader
         java.lang.IllegalStateException: FailedEstablishStatereceived unexpected data on null
         at net.i2p.router.transport.ntcp.EstablishState.receive(EstablishState.java:216)
         at net.i2p.router.transport.ntcp.Reader.processRead(Reader.java:156)
         at net.i2p.router.transport.ntcp.Reader.access$400(Reader.java:21)
         at net.i2p.router.transport.ntcp.Reader$Runner.run(Reader.java:118)
         at java.lang.Thread.run(Thread.java:724)
         at net.i2p.util.I2PThread.run(I2PThread.java:84)

comment:4 Changed 4 years ago by zzz

Milestone: undecided0.9.20
Status: newaccepted

Seen here also. Looks to be harmless. Testing a change to hide it from the logs.

comment:5 Changed 4 years ago by zzz

Resolution: fixed
Status: acceptedclosed

Catch ISE and log as WARN instead of CRIT. Root cause probably not easily fixable. See comments in Reader.

In 056593f30304d03c20c43994cf45f518a69c4f13 to be 0.9.19-22-rc

Note: See TracTickets for help on using tickets.