Opened 4 years ago

Closed 4 years ago

#1545 closed defect (fixed)

Duplicate Shared Clients, Reduce tunnel quantity when idle and Close tunnels when idle has no effect

Reported by: djjeshk Owned by:
Priority: major Milestone: 0.9.20
Component: apps/i2ptunnel Version: 0.9.19
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.19-8
Java version: Oracle Corporation 1.8.0_45 (Java(TM) SE Runtime Environment 1.8.0_45-b14)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized library jbigi-windows-core2.dll loaded from file
Encoding: Cp1257
Charset: windows-1257

My settings in I2P HTTP Proxy and I2P HTTPS Proxy:
Tunnel count: 6 in, 6 out
Reduce tunnel quantity when idle, enabled: checked
Reduced tunnel count: 1
Idle minutes: 5
Close tunnels when idle, enable: checked
New Keys on Reopen: Enable
Idle minutes: 15

Currently I have two destinations named Shared Clients, each using 12 tunnels for a long time and does not regenerate keys at all.

Subtickets

Change History (5)

comment:1 Changed 4 years ago by echelon

A shared clients tunnel is shared and only goes idle if there is no traffic at all.
But looks like you still got traffic on it (e.g. snark or else)

comment:2 Changed 4 years ago by zzz

  • Component changed from unspecified to apps/i2ptunnel

There's a couple things going on here.

1) dup tunnels reproduced here, fixed in 66d0919530ea7978a7e6bb2675679e1d458d9888 0.9.19-28-rc, although could be related to 2) also

2) A problem from the beginning of time is that i2ptunnel shared clients all have to be configured the same (manually), including tunnels that aren't running. If they aren't, maybe the first one wins, or the last one, not sure. If you change one, some of the changes may propagate to other tunnels 9but not saved?), some may not. There's no central place to configure the shared clients tunnel once.

Over the years we've done some handwaving about 'shared client groups', where you could have multiple "named" shared clients, configured in a central place, and you would just set a tunnel to be a member of that group. We've never started any work on that, and I can't find an open ticket or zzz.i2p post on it, but I didn't look very hard.

I don't know how to separate out what's what from the info in the OP. Maybe changing settings caused two tunnels, or maybe two tunnels caused the settings to be ignored, or maybe it's one of the two issues above. Perhaps you can attempt to reproduce on -28 and either clarify what's going on or declare it fixed. If your issue is w.r.t. the configuration and UI issues then that may deserve a separate ticket.

comment:3 Changed 4 years ago by zzz

-28 has a major bug, idle tunnels stay closed, reverted in -29, reworked fix for dup tunnels to follow

comment:4 Changed 4 years ago by zzz

2nd try in ae327a96db27c150dad69dc60af545a5f84242a0 0.9.19-30-rc

comment:5 Changed 4 years ago by zzz

  • Milestone changed from undecided to 0.9.20
  • Resolution set to fixed
  • Status changed from new to closed

Presumed fixed

Note: See TracTickets for help on using tickets.