Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1558 closed enhancement (not a bug)

Handle two reachable router communication problems if it is blocked

Reported by: djjeshk Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.19
Keywords: Cc:
Parent Tickets:

Description

I know two cases when two reachable routers are not able to communicate:

  1. They have not common transports to communicate. For example

:
a) IPv6 only routers with IPv4 only routers
b) SSU only routers with NTCP only routers

For case a we could use Teredo to join IPv4 only routers into IPv6 world and boost performance for IPv6 only routers.
For case b introducers are used, but they are making things even worse, because one transport only enabled router is participating better than one transport firewalled - other not firewalled router.

  1. ISP attempts to interfere if certain country or port is communicated. This looks have effect in Middle East and Far East, and may have effect in other countries. Reachability data should be distributed with routers to let others choose better routes.

Subtickets

Change History (3)

comment:1 Changed 4 years ago by echelon

  • Resolution set to not a bug
  • Status changed from new to closed
  1. it is currently worked on transports, and yeah, IPv6 cannot talk direct to IPv4. Thats technical and intended. Also SSu cannot talk with TCP, thats intended, too. It is not I2P job to make them talk to each other.

Introducers are used to reach UDP transports on closed UDP ports, if available. Introducers does not have anything to do with TCP.

  1. Routers do already distribute reachability data. I2P cannot change ISP behaviour neither work around evil ISPs.

comment:2 Changed 4 years ago by djjeshk

I just want to mention that all russian ISP's may turn evil. From 2015.05.01. at territory of Russian Federation lot of sites are about to be blocked. Tor, VPN's are already kept on eye.

Maybe loss of russian users would not hurt so much.

comment:3 Changed 4 years ago by zzz

This seems to be another issue of router transport compatibility and "restricted routes".

See tickets #1458 #1548 #1188

re: OBEP/IBGW compatibility, see #1188

re: region-specifc, (and also related to #1188), I2P is a "full-mesh' network, meaning it assumes that everybody can connect to everybody. When this is not true, things break. Fixing this is a huge job, and falls under the general topic of "restricted routes', see ​http://zzz.i2p/topics/114

We don't need more tickets on this.

Note: See TracTickets for help on using tickets.