Opened 4 years ago

Closed 4 years ago

#1570 closed task (not a bug)

"C1 CompilerThread0" increased CPU usage

Reported by: djjeshk Owned by:
Priority: maintenance Milestone: undecided
Component: unspecified Version: 0.9.19
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.19-18
Java version: Oracle Corporation 1.8.0_45 (Java(TM) SE Runtime Environment 1.8.0_45-b14)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized library jbigi-windows-core2.dll loaded from file
Encoding: Cp1257
Charset: windows-1257

"C1 CompilerThread0" #6 daemon prio=9 os_prio=2 tid=0x00cbfc00 nid=0x67c waiting on condition [0x00000000]
   java.lang.Thread.State: RUNNABLE
"NTCP Pumper" #79 daemon prio=5 os_prio=0 tid=0x264f3800 nid=0x69c runnable [0x2742f000]
   java.lang.Thread.State: RUNNABLE
	at sun.nio.ch.WindowsSelectorImpl$SubSelector.poll0(Native Method)
	at sun.nio.ch.WindowsSelectorImpl$SubSelector.poll(Unknown Source)
	at sun.nio.ch.WindowsSelectorImpl$SubSelector.access$400(Unknown Source)
	at sun.nio.ch.WindowsSelectorImpl.doSelect(Unknown Source)
	at sun.nio.ch.SelectorImpl.lockAndDoSelect(Unknown Source)
	- locked <0x0f4bd098> (a sun.nio.ch.Util$2)
	- locked <0x0f4bd0a8> (a java.util.Collections$UnmodifiableSet)
	- locked <0x0f4bd020> (a sun.nio.ch.WindowsSelectorImpl)
	at sun.nio.ch.SelectorImpl.select(Unknown Source)
	at net.i2p.router.transport.ntcp.EventPumper.run(EventPumper.java:185)
	at java.lang.Thread.run(Unknown Source)
	at net.i2p.util.I2PThread.run(I2PThread.java:107)

each of them are using about 7-11% of CPU

Subtickets

Change History (3)

comment:1 Changed 4 years ago by echelon

  • Priority changed from minor to maintenance
  • Status changed from new to infoneeded_new
  • Type changed from defect to task

have you done a dump thread?
Is it a I2P thread at all?
What does this report tell us at all?
Need more information.

comment:2 Changed 4 years ago by djjeshk

  • Status changed from infoneeded_new to new
  • Summary changed from "C1 CompilerThread0" increased CPU usage comparable to "NTCP Pumper" to "C1 CompilerThread0" increased CPU usage

I did thread dump twice and yes, C1 CompilerThread0 is using a CPU power
I do not know what threads are not created by I2P, if you do not recognize it as I2P thread, most likely it is from Java runtime.
This report tells that I2P compiles something. It may only do this at JVM startup to interpret java code. Maybe someone coded something wrong, maybe kytv's compiler does something wrong.
If you are I2P developer, you should better know what is Java doing here and why.

comment:3 Changed 4 years ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed

That's the JVM JIT thread.

As in #1571, please do not make inflammatory statements about what people should know and why, we can't take you seriously with that approach.

Note: See TracTickets for help on using tickets.