Opened 5 years ago

Closed 5 years ago

#1577 closed defect (fixed)

FloodfillMonitorJob NPE

Reported by: zzz Owned by: dg
Priority: blocker Milestone: 0.9.20
Component: router/netdb Version: 0.9.19
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Received via email:

Hello, I have this strange report in my log :

15/05/15 04:16:05 CRIT [JobQueue 4/4] net.i2p.router.JobQueueRunner : Error processing job [Monitor the floodfill pool] on thread 3: null
     java.lang.NullPointerException
     at net.i2p.router.networkdb.kademlia.FloodfillMonitorJob.shouldBeFloodfill(FloodfillMonitorJob.java:165)
     at net.i2p.router.networkdb.kademlia.FloodfillMonitorJob.runJob(FloodfillMonitorJob.java:50)
     at net.i2p.router.JobQueueRunner.runCurrentJob(JobQueueRunner.java:134)
     at net.i2p.router.JobQueueRunner.run(JobQueueRunner.java:77)
I2P version: 0.9.19-21-rc
Java version: Oracle Corporation 1.7.0_79 (OpenJDK Runtime Environment 1.7.0_79-b14)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.13.0-37-generic
Jbigi: Locally optimized library libjbigi-linux-athlon64_64.so loaded from file
Encoding: UTF-8
Charset: UTF-8

Subtickets

Change History (1)

comment:1 Changed 5 years ago by dg

Resolution: fixed
Status: newclosed

Thanks to the reporter and zzz.
Caused by router.tunnelBacklog not being a 'required' stat (always generated). Any router without full stats enabled would therefore NPE when checking if ff-eligible.

<+dg> zzz: I can bandaid but I can't reproduce it. Is it possible that CoalesceStatsEvent (SimpleTimer.TimedEvent) isn't working properly? RN was seeing stats issues so that's why I asked
<&zzz> dg, i suspect you can reproduce it with stat.full=false ;)
<feed> [ I2P ] fix on non-full stats routers (thx zzz) 
<feed> doh [dg2-new@mail.i2p] -- http://killyourtv.i2p/viewmtn/revision/info/174649506cd8a9665ad798c090e39481af967011

fix in 174649506cd8a9665ad798c090e39481af967011 -23

Note: See TracTickets for help on using tickets.