Opened 4 years ago

Closed 3 years ago

#1579 closed defect (not our bug)

UDP bad checksum

Reported by: zzz Owned by: zzz
Priority: minor Milestone: undecided
Component: router/transport Version: 0.9.19
Keywords: Cc:
Parent Tickets:

Description

On a medium-speed non-ipv6 router. At least one source IP below verified to be an I2P router, probably Java. Don't see any changes that could cause this after .19. Perhaps a .19 problem?

Possibly related: #1538

Subtickets

Change History (4)

comment:1 Changed 4 years ago by zzz

From dmesg:

[Mon Apr 27 16:30:45 2015] UDP: bad checksum. From xx.xx.48.78:57209 to x.x.x.x:yyyy ulen 67
[Tue Apr 28 00:56:53 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 01:03:56 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 01:19:58 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 01:43:52 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 01:55:56 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 02:26:33 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 02:39:36 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 04:05:44 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 05:59:05 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 06:11:18 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 07:18:46 2015] UDP: bad checksum. From xx.xx.153.124:1024 to x.x.x.x:yyyy ulen 8
[Tue Apr 28 13:25:27 2015] UDP: bad checksum. From xx.xx.247.72:28102 to x.x.x.x:yyyy ulen 8
[Wed Apr 29 10:26:10 2015] UDP: bad checksum. From xx.xx.48.78:63317 to x.x.x.x:yyyy ulen 65
[Fri May  8 03:20:07 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 66
[Fri May  8 03:20:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 67
[Fri May  8 03:21:19 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 64
[Fri May  8 03:21:43 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 66
[Fri May  8 03:22:31 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 61
[Fri May  8 03:22:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 69
[Fri May  8 03:25:43 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 64
[Fri May  8 03:26:07 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 64
[Fri May  8 03:26:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 67
[Fri May  8 03:28:07 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 59
[Fri May  8 03:29:43 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 63
[Fri May  8 03:30:07 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 64
[Fri May  8 03:30:31 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 60
[Fri May  8 03:30:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 59
[Fri May  8 03:31:43 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 63
[Fri May  8 03:32:31 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 56
[Fri May  8 03:32:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 71
[Fri May  8 03:33:19 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 62
[Fri May  8 03:34:31 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 67
[Fri May  8 03:34:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 56
[Fri May  8 03:35:19 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 64
[Fri May  8 03:35:43 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 63
[Fri May  8 03:36:07 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 65
[Fri May  8 03:36:31 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 68
[Fri May  8 03:36:55 2015] UDP: bad checksum. From xx.xx.86.33:22088 to x.x.x.x:yyyy ulen 62
[Sat May  9 04:58:56 2015] UDP: bad checksum. From xx.xx.246.191:31006 to x.x.x.x:yyyy ulen 66
[Mon May 11 13:07:33 2015] UDP: bad checksum. From xx.xx.46.100:28760 to x.x.x.x:yyyy ulen 71
[Mon May 11 14:01:34 2015] UDP: bad checksum. From xx.xx.46.100:3434 to x.x.x.x:yyyy ulen 59
[Mon May 11 14:08:58 2015] UDP: bad checksum. From xx.xx.46.100:45731 to x.x.x.x:yyyy ulen 64
[Tue May 12 15:36:38 2015] UDP: bad checksum. From xx.xx.23.174:65403 to x.x.x.x:yyyy ulen 8
[Tue May 12 16:12:51 2015] UDP: bad checksum. From xx.xx.23.174:25641 to x.x.x.x:yyyy ulen 8
[Tue May 12 17:00:23 2015] UDP: bad checksum. From xx.xx.23.174:43528 to x.x.x.x:yyyy ulen 8
[Tue May 12 18:07:34 2015] UDP: bad checksum. From xx.xx.23.174:64911 to x.x.x.x:yyyy ulen 8
[Tue May 12 19:17:13 2015] UDP: bad checksum. From xx.xx.23.174:33056 to x.x.x.x:yyyy ulen 8
[Tue May 12 19:42:25 2015] UDP: bad checksum. From xx.xx.23.174:18128 to x.x.x.x:yyyy ulen 8
[Tue May 12 20:33:50 2015] UDP: bad checksum. From xx.xx.23.174:42375 to x.x.x.x:yyyy ulen 8
[Tue May 12 20:41:44 2015] UDP: bad checksum. From xx.xx.23.174:61211 to x.x.x.x:yyyy ulen 8
[Tue May 12 21:52:18 2015] UDP: bad checksum. From xx.xx.23.174:34191 to x.x.x.x:yyyy ulen 8
[Tue May 12 23:07:41 2015] UDP: bad checksum. From xx.xx.23.174:54298 to x.x.x.x:yyyy ulen 8
[Wed May 13 03:17:10 2015] UDP: bad checksum. From xx.xx.45.216:29320 to x.x.x.x:yyyy ulen 76
[Wed May 13 08:46:29 2015] UDP: bad checksum. From xx.xx.23.174:23173 to x.x.x.x:yyyy ulen 8
[Wed May 13 09:38:13 2015] UDP: bad checksum. From xx.xx.23.174:2172 to x.x.x.x:yyyy ulen 8
[Wed May 13 09:57:31 2015] UDP: bad checksum. From xx.xx.23.174:18158 to x.x.x.x:yyyy ulen 8
[Wed May 13 10:15:45 2015] UDP: bad checksum. From xx.xx.23.174:52346 to x.x.x.x:yyyy ulen 8
[Wed May 13 13:32:43 2015] UDP: bad checksum. From xx.xx.23.174:53931 to x.x.x.x:yyyy ulen 8
[Wed May 13 13:45:54 2015] UDP: bad checksum. From xx.xx.23.174:27455 to x.x.x.x:yyyy ulen 8
[Thu May 14 00:43:44 2015] UDP: bad checksum. From xx.xx.15.22:65535 to x.x.x.x:yyyy ulen 8
[Sat May 16 04:55:09 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 76
[Sat May 16 04:55:54 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 69
[Sat May 16 05:56:29 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 61
[Sat May 16 05:56:32 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 58
[Sat May 16 06:05:35 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 73
[Sat May 16 06:23:45 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 60
[Sat May 16 06:30:15 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 60
[Sat May 16 06:40:35 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 65
[Sat May 16 06:51:06 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 65
[Sat May 16 07:16:16 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 58
[Sat May 16 07:33:44 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 59
[Sat May 16 07:39:28 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 64
[Sat May 16 07:59:04 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 73
[Sat May 16 07:59:08 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 58
[Sat May 16 08:09:11 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 69
[Sat May 16 08:31:44 2015] UDP: bad checksum. From xx.xx.109.17:19137 to x.x.x.x:yyyy ulen 56

comment:2 Changed 4 years ago by dg

from #i2p-dev (edited for brevity):

<&zzz>  anybody else seeing bad UDP checksums in dmesg?
<+dg>   dmesg | grep "bad checksum" -c => 35
<&zzz>  they are all to my i2p port. A lot of 8-byte, and a lot of 56 to 76 byte
<&zzz>  i verified one source as a live i2p router, apparently java
<+dg>   28, 26 mostly and a few larger
<&zzz>  last time we had a bunch of these it was a bad ssu bug
<+dg>   this isn't particularly new for me but i didn't think it was related to i2p (stupid)
<+dg>   various lengths from the same ip in a row
<&zzz>  #1538 may be related
<&zzz>  mine go back to apr. 27 but that may be about when i rebooted
<+dg>   mine say 19th april

points to .19?
I've seen "short packet" in dmesg in addition to the OP issue.

Last edited 4 years ago by dg (previous) (diff)

comment:3 Changed 4 years ago by zzz

suspected to be caused by ancient, buggy i2pd, but not confirmed

comment:4 Changed 3 years ago by zzz

  • Resolution set to not our bug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.