Opened 4 years ago

Closed 2 years ago

#1586 closed defect (fixed)

I2P-Bote ConcurrentModificationException

Reported by: hummingbird Owned by: HungryHobo
Priority: minor Milestone: 0.9.21
Component: apps/other Version: 0.9.19
Keywords: I2P-Bote Cc:
Parent Tickets:

Description

I2P running since 15 hours. I did not have this issue before using 0.9.19-31 (I used 0.9.19-30 before).

I2P version: 0.9.19-31-rc
Java version: Oracle Corporation 1.7.0_79 (OpenJDK Runtime Environment 1.7.0_79-b14)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.13.0-37-generic
Jbigi: Locally optimized library libjbigi-linux-athlon64_64.so loaded from file
Encoding: UTF-8
Charset: UTF-8

28/05/15 15:55:39 ERROR [e Jetty-2157] i2p.bote.service.EmailChecker? : Error while checking whether new mail has arrived.

java.util.concurrent.ExecutionException?: java.util.concurrent.ExecutionException?: java.util.ConcurrentModificationException?
at java.util.concurrent.FutureTask?.report(FutureTask?.java:122)
at java.util.concurrent.FutureTask?.get(FutureTask?.java:202)
at i2p.bote.service.EmailChecker?.newMailReceived(EmailChecker?.java:158)
at i2p.bote.I2PBote.newMailReceived(I2PBote.java:566)
at i2p.bote.util.GeneralHelper?.isNewMailReceived(GeneralHelper?.java:330)
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at javax.el.BeanELResolver.getValue(BeanELResolver.java:83)
at javax.el.CompositeELResolver.getValue(CompositeELResolver.java:54)
at org.apache.el.parser.AstValue?.getValue(AstValue?.java:123)
at org.apache.el.ValueExpressionImpl?.getValue(ValueExpressionImpl?.java:182)
at org.apache.jasper.runtime.PageContextImpl?.proprietaryEvaluate(PageContextImpl?.java:919)
at i2p.bote.jsp.buttonFrame_jsp._jspx_meth_c_005fif_005f8(buttonFrame_jsp.java:824)
at i2p.bote.jsp.buttonFrame_jsp._jspx_meth_c_005fif_005f4(buttonFrame_jsp.java:423)
at i2p.bote.jsp.buttonFrame_jsp._jspService(buttonFrame_jsp.java:115)
at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:70)
at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:848)
at org.eclipse.jetty.servlet.ServletHolder?.handle(ServletHolder?.java:684)
at org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(ServletHandler?.java:1496)
at i2p.bote.web.CharsetFilter?.doFilter(CharsetFilter?.java:38)
at org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(ServletHandler?.java:1476)
at org.eclipse.jetty.servlet.ServletHandler?.doHandle(ServletHandler?.java:501)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:137)
at org.eclipse.jetty.security.SecurityHandler?.handle(SecurityHandler?.java:557)
at org.eclipse.jetty.server.session.SessionHandler?.doHandle(SessionHandler?.java:231)
at org.eclipse.jetty.server.handler.ContextHandler?.doHandle(ContextHandler?.java:1086)
at org.eclipse.jetty.servlet.ServletHandler?.doScope(ServletHandler?.java:429)
at org.eclipse.jetty.server.session.SessionHandler?.doScope(SessionHandler?.java:193)
at org.eclipse.jetty.server.handler.ContextHandler?.doScope(ContextHandler?.java:1020)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:135)
at org.eclipse.jetty.server.handler.ContextHandlerCollection?.handle(ContextHandlerCollection?.java:255)
at org.eclipse.jetty.server.handler.HandlerCollection?.handle(HandlerCollection?.java:154)
at org.eclipse.jetty.server.handler.HandlerWrapper?.handle(HandlerWrapper?.java:116)
at org.eclipse.jetty.server.Server.handle(Server.java:370)
at org.eclipse.jetty.server.AbstractHttpConnection?.handleRequest(AbstractHttpConnection?.java:494)
at org.eclipse.jetty.server.AbstractHttpConnection?.headerComplete(AbstractHttpConnection?.java:971)
at org.eclipse.jetty.server.AbstractHttpConnection?$RequestHandler?.headerComplete(AbstractHttpConnection?.java:1033)
at org.eclipse.jetty.http.HttpParser?.parseNext(HttpParser?.java:644)
at org.eclipse.jetty.http.HttpParser?.parseAvailable(HttpParser?.java:235)
at org.eclipse.jetty.server.AsyncHttpConnection?.handle(AsyncHttpConnection?.java:82)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?.handle(SelectChannelEndPoint?.java:696)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?$1.run(SelectChannelEndPoint?.java:53)
at org.eclipse.jetty.util.thread.QueuedThreadPool?.runJob(QueuedThreadPool?.java:608)
at org.eclipse.jetty.util.thread.QueuedThreadPool?$3.run(QueuedThreadPool?.java:543)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.util.concurrent.ExecutionException?: java.util.ConcurrentModificationException?
at java.util.concurrent.FutureTask?.report(FutureTask?.java:122)
at java.util.concurrent.FutureTask?.get(FutureTask?.java:202)
at i2p.bote.network.CheckEmailTask?.call(CheckEmailTask?.java:131)
at i2p.bote.network.CheckEmailTask?.call(CheckEmailTask?.java:61)
at java.util.concurrent.FutureTask?.run(FutureTask?.java:262)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
... 1 more
Caused by: java.util.ConcurrentModificationException?
at java.util.ArrayList?$Itr.checkForComodification(ArrayList?.java:859)
at java.util.ArrayList?$Itr.next(ArrayList?.java:831)
at i2p.bote.network.kademlia.BucketManager?.getAllUnlockedPeers(BucketManager?.java:267)
at i2p.bote.network.kademlia.ClosestNodesLookupTask?.call(ClosestNodesLookupTask?.java:106)
at i2p.bote.network.kademlia.KademliaDHT.getClosestNodes(KademliaDHT.java:179)
at i2p.bote.network.kademlia.KademliaDHT.find(KademliaDHT.java:262)
at i2p.bote.network.kademlia.KademliaDHT.findAll(KademliaDHT.java:189)
at i2p.bote.network.CheckEmailTask?$EmailPacketTask?.run(CheckEmailTask?.java:201)
at java.util.concurrent.Executors$RunnableAdapter?.call(Executors.java:471)
... 4 more

28/05/15 05:10:39 ERROR [UpdateCheckr?] i2p.bote.service.UpdateChecker?: Can't check update URL: http://tjgidoycrw6s3guetge3kvrvynppqjmvqsosmtbmgqasa6vmsf6a.b32.i2p/i2pbote-update.xpi2p

Subtickets

Change History (4)

comment:1 Changed 4 years ago by hummingbird

  • Owner set to HungryHobo
  • Status changed from new to assigned

comment:2 Changed 4 years ago by str4d

  • Milestone changed from undecided to 0.9.21
  • Status changed from assigned to testing

Update checker has been dropped from trunk by HungryHobo? (it was there before I2P did automatic plugin update checks).

ConcurrentModificationException fixed in 50f06182e970d4eb7d371f6c5bf157f63c00a636.

Version 0, edited 4 years ago by str4d (next)

comment:3 Changed 4 years ago by str4d

  • Summary changed from Issue in I2P-Bote to I2P-Bote ConcurrentModificationException

comment:4 Changed 2 years ago by str4d

  • Resolution set to fixed
  • Status changed from testing to closed

No further reports, optimistically closing.

Note: See TracTickets for help on using tickets.