Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1587 closed defect (fixed)

Setting +/- option in variance at I2P Hidden Service settings has no effect

Reported by: DjJeshk Owned by:
Priority: minor Milestone: 0.9.20
Component: apps/i2ptunnel Version: 0.9.19
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.19-30-rc
Java version: Oracle Corporation 1.8.0_45 (Java™ SE Runtime Environment 1.8.0_45-b15)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized library jbigi-windows-core2.dll loaded from file
Encoding: Cp1257
Charset: windows-1257

± option in variance looks disabled.

How to reproduce:
Open /i2ptunnel/edit?tunnel=0 (or other number than zero)
Set ± setting in variance and save
Look again at /i2ptunnel/edit?tunnel=0

PS. Do we need such unstable setting that generates tunnels with length 2, 3 and 4 at same time?

PPS.
I was testing +0-1 hop variance setting and it generates approx 25% tunnels with length 3 and 75% tunnels with length 2 if you have set 2 at tunnel length.
It would be great to enable setting average tunnel length to not integer value like 2.6 . It would be interpreted as 60% tunnels with length 3 and 40% tunnels with length 2. Setting 2 is less anonymous but about two-three times faster than option 3, but setting tunnel length larger than 3 has negative benefit in anonymity and speed, so it should be implemented for testing purposes.

Subtickets

Change History (4)

comment:1 Changed 4 years ago by dg

Status: newinfoneeded_new

Could you clarify if, when testing, you were using 0.9.19?
Did you observe the issue happening in 0.9.19 or just -30?

Using Linux with -31-rc, I can't reproduce this issue. The setting persists and the tunnels built are also displaying variance.

I'll defer comment for now on the usefulness of the field to zzz.

comment:2 Changed 4 years ago by DjJeshk

Status: infoneeded_newnew

Could not give more clarification, because I do not guarantee a truth of memories that were too long ago. I will try with -31, but http://killyourtv.i2p/viewmtn/branch/changes/i2p.i2p does not mention anything about it, so issue should not disappear for me.

Last edited 4 years ago by DjJeshk (previous) (diff)

comment:3 Changed 4 years ago by zzz

Component: unspecifiedapps/i2ptunnel
Milestone: undecided0.9.20
Resolution: fixed
Status: newclosed

Fixed in 53e2836926eaf521549334439ca416a7e115f447 0.9.19-33-rc.
Only ± variance was broken, the + variance was fine.
Broken in mid-March by str4d's config refactoring.

comment:4 Changed 4 years ago by zzz

re: PS, not a widely used option, use it or don't, it's not hurting anything.

re: PPS, we're unlikely to ever do that, but if you really want it, put it in a separate ticket and state your case.

Note: See TracTickets for help on using tickets.