Opened 4 years ago

Closed 4 years ago

#1588 closed defect (not a bug)

I2PSnark tunnel count after some hours resets to 2

Reported by: djjeshk Owned by: zzz
Priority: minor Milestone: undecided
Component: apps/i2psnark Version: 0.9.19
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.19-30-rc
Java version: Oracle Corporation 1.8.0_45 (Java(TM) SE Runtime Environment 1.8.0_45-b15)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized library jbigi-windows-core2.dll loaded from file
Encoding: Cp1257
Charset: windows-1257

I have set tunnel count in i2psnark settings to 6, but after some time (day) /tunnels page shows only 2 tunnels each direction. It is a network saving option? Have not seen it in 0.9.19-0 and earlier versions.

Subtickets

Change History (4)

comment:1 Changed 4 years ago by dg

  • Status changed from new to infoneeded_new

This change is in 0.9.19, it reduces the amount of tunnels if we have more tunnels than we have peers:

---
| | | |   Revision: de6524ac38282bacf35c0d9bcdb4e1d404bb8dbf
| | | |   Parent:   3a30c14d4afaf659601cfcf72eea5165a79a5f06
| | | |   Author:   zzz@mail.i2p
| | | |   Date:     03/13/15 10:56:35
| | | |   Branch:   i2p.i2p
| | | |   
| | | |   Changelog: 
| | | |   
| | | |   i2psnark:
| | | |     - Auto-reduce tunnel quantity based on peer count
| | | |     - Increase max tunnels
| | | |   
| | | |   Changes against parent 3a30c14d4afaf659601cfcf72eea5165a79a5f06
| | | |   
| | | |     patched  apps/i2psnark/java/src/org/klomp/snark/IdleChecker.java
| | | |     patched  apps/i2psnark/java/src/org/klomp/snark/web/I2PSnarkServlet.java

It was added as part of an effort to reduce network load, as there is no point in I2PSnark clients creating tunnels when they are not required or in use.

Could you tell us how active the torrents you have are?
How many are added, how many seeds and peers do each have?
Did you set the tunnel count to 6 for both inbound and outbound?

Version 1, edited 4 years ago by dg (previous) (next) (diff)

comment:2 Changed 4 years ago by djjeshk

  • Status changed from infoneeded_new to new

6 in both directions, yes.
I have 329 DHT , usually I had 700-1000 peers.

When i first saw it i had at least 5 active torrents with no other seeders and 2-5 leechers for each. Speed was pretty low compared to ealier versions. I will try to tell I2PSnark to remove that limit by only adding more torrents.

Last edited 4 years ago by djjeshk (previous) (diff)

comment:3 Changed 4 years ago by djjeshk

Tunnel count back to normal at:
14 torrents, 39,58 GB, 12 connected peers, 418 DHT peers 0 Bps down, 17 KBps Up

comment:4 Changed 4 years ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed

The auto-reduce code is based on connected peers, not DHT peers. It reduces to 1 tunnel if no peers, 2 tunnels for 1-5 peers, and (peers/2) tunnels for 6+ peers. This allows you to configure a high number of tunnels without wasting resources if they aren't needed.

All this was in the 0.9.19 release and was noted briefly in the release notes, but not otherwise documented. We could of course tweak the algorithm in a future release if needed, but I haven't heard any complaints so far.

Closing not-a-bug.

Note: See TracTickets for help on using tickets.