Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1591 closed enhancement (wontfix)

Lease set not found error does not appears to user if address like hostname.i2p is requested

Reported by: DjJeshk Owned by:
Priority: minor Milestone: n/a
Component: unspecified Version: 0.9.19
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.19-34-rc
Java version: Oracle Corporation 1.8.0_45 (Java™ SE Runtime Environment 1.8.0_45-b15)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: Core 2 (45nm) (core2)
Jbigi: Locally optimized library jbigi-windows-core2.dll loaded from file
Encoding: Cp1257
Charset: windows-1257

How to reproduce:
To see warnings, you need to set Default log level to WARN in /configlogging .
You maybe need to set these log level overrides to filter out some log flood:

net.i2p.client.streaming.I2PSocketEepGet=ERROR
net.i2p.client.streaming.impl.Connection=ERROR
net.i2p.router.crypto.TransientSessionKeyManager=ERROR
net.i2p.router.message.OutboundClientMessageOneShotJob=ERROR

If dead i2p website is requested using hostname, three warning appears at router log and user only see Could not find the following destination error:

15.1.6 01:16:04 WARN [al Reader 56] ent.streaming.impl.PacketQueue: LS lookup (soft) failure for msg 47 on [Connection filteredout/unknown to filteredout up 45s wsize: 3 cwin: 6 rtt: 0 rto: 9000 unacked out: 1 unacked in: 0 sent: 1 rcvd: 0 ackThru -1 maxWin 128 MTU 1730]
15.1.6 01:15:34 WARN [al Reader 56] ent.streaming.impl.PacketQueue: LS lookup (soft) failure for msg 46 on [Connection filteredout/unknown to filteredout up 15s wsize: 3 cwin: 6 rtt: 0 rto: 9000 unacked out: 1 unacked in: 0 sent: 1 rcvd: 0 ackThru -1 maxWin 128 MTU 1730]
15.1.6 01:15:34 WARN [al Reader 56] ent.streaming.impl.PacketQueue: LS lookup (soft) failure for msg 45 on [Connection filteredout/unknown to filteredout up 15s wsize: 3 cwin: 6 rtt: 0 rto: 9000 unacked out: 1 unacked in: 0 sent: 1 rcvd: 0 ackThru -1 maxWin 128 MTU 1730]

If dead i2p website is requested using b32 address, one warning appears at router log and user sees these two: Could not find the following destination and Destination lease set not found

15.1.6 01:21:58 WARN [nt Runner 71] .i2ptunnel.I2PTunnelHTTPClient: Unable to resolve filteredout.b32.i2p (proxy? false, request: http://filteredout.b32.i2p/

Expected result: same warning count and same response to user

Subtickets

Change History (2)

comment:1 Changed 5 years ago by Eche|on

Milestone: undecidedn/a
Resolution: wontfix
Status: newclosed
Type: defectenhancement

Warn messages do appear if you set log level to warn, quite usual.
The bug/wish item seems to be to show "leaseset not found" error in html. That is already implemented.
Also if a dns is not able to be resolved, the error message is enough for users.
We do not want to show too complex information for the users. KISS is the way it works in here, experts and andvanced users CAN set warn log level and see the error itself.

comment:2 Changed 5 years ago by DjJeshk

Then why it is shown when base 32 address is requested? Usual users might access them too, for example, test website without adding it on addressbook.

Note: See TracTickets for help on using tickets.