Opened 4 years ago

Closed 4 years ago

#1594 closed defect (fixed)

jbigi not available on raspberry pi 2

Reported by: Plugh Plover Owned by:
Priority: major Milestone: 0.9.20
Component: api/crypto Version: 0.9.20
Keywords: Cc:
Parent Tickets: #1216 Sensitive: no

Description

i2p noob here…

on a raspberry pi 2, running fresh install of the current
05-05-2015 raspian image, installed i2p 0.9.19-3~deb7u+1 as per
https://geti2p.net/en/download/debian#debian

The following extra packages will be installed:
  i2p-router killyourtv-keyring libecj-java libjbigi-jni
  libservice-wrapper-java libservice-wrapper-jni service-wrapper ttf-dejavu
  ttf-dejavu-extra
Suggested packages:
  tor apparmor i2p-messenger i2phex i2p-tahoe-lafs imule irc-client itoopie
  mail-client mail-reader news-reader polipo privoxy robert syndie
  xul-ext-torbutton ecj ant libecj-java-gcj libservice-wrapper-doc
The following NEW packages will be installed:
  i2p i2p-keyring i2p-router killyourtv-keyring libecj-java libjbigi-jni
  libservice-wrapper-java libservice-wrapper-jni service-wrapper ttf-dejavu
  ttf-dejavu-extra
0 upgraded, 11 newly installed, 0 to remove and 0 not upgraded.
Need to get 14.1 MB of archives.
After this operation, 23.6 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://deb.i2p2.no/ wheezy/main i2p-router all 0.9.19-3~deb7u+1 [10.7 MB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main ttf-dejavu-extra all 2.33-3 [1,759 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main ttf-dejavu all 2.33-3 [30.6 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libecj-java all 3.5.1-3 [1,238 kB]
Get:5 http://deb.i2p2.no/ wheezy/main libjbigi-jni armhf 0.9.19-1~deb7u+1 [2,870 B]
Get:6 http://deb.i2p2.no/ wheezy/main libservice-wrapper-java all 3.5.25-1~deb7u+1 [221 kB]
Get:7 http://deb.i2p2.no/ wheezy/main libservice-wrapper-jni armhf 3.5.25-1~deb7u+1 [14.3 kB]
Get:8 http://deb.i2p2.no/ wheezy/main service-wrapper armhf 3.5.25-1~deb7u+1 [162 kB]
Get:9 http://deb.i2p2.no/ wheezy/main i2p all 0.9.19-3~deb7u+1 [33.8 kB]
Get:10 http://deb.i2p2.no/ wheezy/main i2p-keyring all 2014.09.25 [9,740 B]
Get:11 http://deb.i2p2.no/ wheezy/main killyourtv-keyring all 2015.03.27.1 [12.9 kB]
Setting up ttf-dejavu-extra (2.33-3) ...
Setting up ttf-dejavu (2.33-3) ...
Setting up libecj-java (3.5.1-3) ...
Setting up i2p-router (0.9.19-3~deb7u+1) ...
Setting up libjbigi-jni (0.9.19-1~deb7u+1) ...
Setting up i2p-keyring (2014.09.25) ...
Setting up killyourtv-keyring (2015.03.27.1) ...
Setting up libservice-wrapper-jni (3.5.25-1~deb7u+1) ...
Setting up service-wrapper (3.5.25-1~deb7u+1) ...
Setting up i2p (0.9.19-3~deb7u+1) ...
[info] I2P Router daemon disabled in /etc/default/i2p..
Setting up libservice-wrapper-java (3.5.25-1~deb7u+1) ...

logged during startup

Successfully copied data files to new user directory /home/pi/.i2p
INFO: Resource name [libjbigi-linux-armv7.so] was not found
INFO: Resource name [libjbigi-linux-armv6.so] was not found
INFO: Resource name [libjbigi-linux-armv5.so] was not found
INFO: Resource name [libjbigi-linux-armv4.so] was not found
INFO: Resource name [libjbigi-linux-armv3.so] was not found
INFO: Resource name [libjbigi-linux-arm.so] was not found
WARNING: Native BigInteger library jbigi not loaded - using pure Java - poor performance may result - see http://i2p-projekt.i2p/jbigi for help

Is this the file??

~$ ls -al /usr/lib/jni
total 60
drwxr-xr-x  2 root root  4096 May 31 17:12 .
drwxr-xr-x 74 root root 12288 May 31 17:12 ..
-rw-r--r--  1 root root  5312 Apr 13 10:13 libjbigi.so
-rw-r--r--  1 root root 34540 Jul 27  2014 libwrapper.so

There does not appear to be any update to libjbigi-jni available

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
   i2p (0.9.19-3~deb7u+1 => 0.9.20-1~deb7u+1)
   i2p-router (0.9.19-3~deb7u+1 => 0.9.20-1~deb7u+1)
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.8 MB of archives.
After this operation, 108 kB of additional disk space will be used.
Do you want to continue [Y/n]? N
Abort.

So what do I do?
Is https://geti2p.net/en/misc/jbigi (still*) relevant?

*N.B. https://trac.i2p2.de/ticket/1216#comment:9

Changed 2 weeks ago by tuna 

    Note to self: Update ​https://geti2p.net/en/misc/jbigi

FWIW - Unfortunately I did not jot the exact numbers down, but after approx. 40 hours uptime the crypto.elGamal.decrypt and crypto.elGamal.encrypt values were around 1500 and 180 as I recall.

Subtickets

Change History (2)

comment:1 Changed 4 years ago by killyourtv

Status: newtesting

The problem was caused by needing to re-setup my rpi build VM. Packages for Raspbian Wheezy have been uploaded.

comment:2 Changed 4 years ago by killyourtv

Milestone: undecided0.9.20
Resolution: fixed
Status: testingclosed

…and received confirmation in email that the problem's been resolved.

Note: See TracTickets for help on using tickets.