Opened 4 years ago

Closed 4 years ago

#1597 closed defect (fixed)

I2P-Bote NPE

Reported by: killyourtv Owned by: HungryHobo
Priority: minor Milestone: 0.9.21
Component: apps/plugins Version: 0.9.20
Keywords: I2P-Bote Cc: str4d
Parent Tickets: Sensitive: no

Description

I2P 0.9.20
OpenJDK 1.7.0_79-b14

6/7/15 6:28:36 PM ERROR [ConnectTask ] i2p.bote.I2PBote : Can't initialize the application.
     java.lang.NullPointerException
     at i2p.bote.I2PBote.initializeSession(I2PBote.java:294)
     at i2p.bote.I2PBote.access$600(I2PBote.java:127)
     at i2p.bote.I2PBote$ConnectTask.run(I2PBote.java:954)
6/7/15 6:28:36 PM ERROR [ConnectTask ] i2p.bote.I2PBote : Error creating I2PSocketManagerFactory
6/7/15 6:28:36 PM ERROR [ConnectTask ] eaming.I2PSocketManagerFactory: Error creating session for socket manager
     net.i2p.client.I2PSessionException: [I2P-Bote #23179]: Cannot connect to the router on [internal connection]:0
     at net.i2p.client.I2PSessionImpl.connect(I2PSessionImpl.java:559)
     at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:244)
     at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:166)
     at net.i2p.client.streaming.I2PSocketManagerFactory.createManager(I2PSocketManagerFactory.java:145)
     at i2p.bote.I2PBote.initializeSession(I2PBote.java:282)
     at i2p.bote.I2PBote.access$600(I2PBote.java:127)
     at i2p.bote.I2PBote$ConnectTask.run(I2PBote.java:954)
     Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
     at net.i2p.client.I2PSessionImpl.connect(I2PSessionImpl.java:536)
     ... 6 more

Subtickets

Change History (1)

comment:1 Changed 4 years ago by str4d

Milestone: undecided0.9.21
Resolution: fixed
Status: newclosed

This was fixed 7 months ago in 455772b2a5e9f7ed13bdd6bb883d2a471092627f, but the last I2P-Bote plugin release was a year ago, hence why this is still visible. A better error will be thrown after the next plugin release.

Note: See TracTickets for help on using tickets.