Opened 11 years ago

Closed 11 years ago

#16 closed defect (fixed)

Array index out of bounds in NTCP reader.

Reported by: hottuna / Robert Owned by:
Priority: minor Milestone: 0.7.1
Component: router/general Version:
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

INFO   | jvm 4    | 2009/03/27 04:19:17 | 03:19:16.363 CRIT  [NTCP read 1 ] p.router.transport.ntcp.Reader: Error in the ntcp reader
INFO   | jvm 4    | 2009/03/27 04:19:17 | java.lang.ArrayIndexOutOfBoundsException
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at java.lang.System.arraycopy(Native Method)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.data.i2np.TunnelGatewayMessage.writeMessageBody(TunnelGatewayMessage.java:78)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.data.i2np.I2NPMessageImpl.toByteArray(I2NPMessageImpl.java:216)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection.bufferedPrepare(NTCPConnection.java:659)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection.send(NTCPConnection.java:286)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPTransport.outboundMessageReady(NTCPTransport.java:193)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.TransportImpl.send(TransportImpl.java:336)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.GetBidsJob.getBids(GetBidsJob.java:80)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.CommSystemFacadeImpl.processMessage(CommSystemFacadeImpl.java:121)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.OutNetMessagePool.add(OutNetMessagePool.java:61)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.tunnel.TunnelParticipant.send(TunnelParticipant.java:169)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.tunnel.TunnelParticipant.dispatch(TunnelParticipant.java:86)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.tunnel.TunnelDispatcher.dispatch(TunnelDispatcher.java:342)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.InNetMessagePool.doShortCircuitTunnelData(InNetMessagePool.java:301)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.InNetMessagePool.shortCircuitTunnelData(InNetMessagePool.java:286)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.InNetMessagePool.add(InNetMessagePool.java:155)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.TransportManager.messageReceived(TransportManager.java:335)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.TransportImpl.messageReceived(TransportImpl.java:395)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection$ReadState.receiveLastBlock(NTCPConnection.java:1252)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection$ReadState.receiveSubsequent(NTCPConnection.java:1215)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection$ReadState.receiveBlock(NTCPConnection.java:1172)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection.recvUnencryptedI2NP(NTCPConnection.java:1016)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.NTCPConnection.recvEncryptedI2NP(NTCPConnection.java:999)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.Reader.processRead(Reader.java:167)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.Reader.access$400(Reader.java:17)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.router.transport.ntcp.Reader$Runner.run(Reader.java:106)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at java.lang.Thread.run(Unknown Source)
INFO   | jvm 4    | 2009/03/27 04:19:17 | 	at net.i2p.util.I2PThread.run(I2PThread.java:71)

Subtickets

Change History (1)

comment:1 Changed 11 years ago by zzz

Milestone: 0.7.1
Resolution: fixed
Status: newclosed

Also reported at http://forum.i2p/viewtopic.php?t=3027
Exception caught in TunnelGatewayMessage?, root cause stillunknown.
0.7-11

Note: See TracTickets for help on using tickets.