Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1602 closed defect (fixed)

snark npe soon after start-up

Reported by: user Owned by: zzz
Priority: minor Milestone: 0.9.21
Component: apps/i2psnark Version: 0.9.20
Keywords: Cc:
Parent Tickets:

Description

[code]2015/06/12 16:09:38 | Thread terminated unexpectedly: Snark DirMonitor?
2015/06/12 16:09:38 | java.lang.NullPointerException?
2015/06/12 16:09:38 | at org.klomp.snark.SnarkManager?.cleanupTorrentStatus(SnarkManager?.java:1741)
2015/06/12 16:09:38 | at org.klomp.snark.SnarkManager?.access$1500(SnarkManager?.java:51)
2015/06/12 16:09:38 | at org.klomp.snark.SnarkManager?$DirMonitor?.run(SnarkManager?.java:1956)
2015/06/12 16:09:38 | at java.lang.Thread.run(Thread.java:745)
2015/06/12 16:09:38 | at net.i2p.util.I2PThread.run(I2PThread.java:107)
code

Subtickets

Change History (3)

comment:1 Changed 4 years ago by zzz

  • Milestone changed from undecided to 0.9.21
  • Status changed from new to accepted

caused by magnet

comment:2 Changed 4 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in 2aa8c0431e1a8e30bc79d9cfea2e82028d301355 0.9.20-5

comment:3 Changed 4 years ago by user

thanks

Note: See TracTickets for help on using tickets.