Opened 4 years ago

Closed 3 years ago

#1604 closed defect (fixed)

Static content will become invalid if port, tunnel ID and other configuration is changed

Reported by: djjeshk Owned by:
Priority: minor Milestone: 0.9.24
Component: installer Version: 0.9.20
Keywords: Cc:
Parent Tickets:

Description

0.9.20 installation executable generates lot of static content that can be invalidated by changing configuration. This affects http-html templates, documentation, port and some other linked configuration. Regex [0-9][0-9][0-9] should hint to most affected files. Hard-coded tunnel id 0 may appear in other files too.
This was detected by examining installed but not executed 0.9.20 I2P installation picked from https://geti2p.net/en/download

My proposed TODO:
(x) Rebuild whole documentation and templates if configuration changes
(x) Add advanced configuration options in installer
(x) Add comment in configuration files where affected option needs to be edited in more than one file (for example server-client configuration)
(x) Replace static files to dynamic content


Subtickets

Change History (7)

comment:1 Changed 4 years ago by zzz

  • Status changed from new to infoneeded_new

I don't understand this at all. Please provide example of what config you changed, how you changed it, and what has to be done. Are you changing some config after first run, or (somehow?) before?

Is this some theoretical problem you've come up with by "examining", or an actual issue?

comment:2 Changed 4 years ago by djjeshk

  • Status changed from infoneeded_new to new

Below I2P SERVICES you should find link Website which points at http://127.0.0.1:7658/. I changed my website port to 17658 at /configclients and at /i2ptunnelmgr but mentioned Website link still points at http://127.0.0.1:7658/ . Do you understand?

I increased all port numbers by 10000, that is all.

comment:3 Changed 4 years ago by zzz

Is this a real problem or theoretical?

OP implies there's other things besides eepsite port? If you have others, please list them.

comment:4 Changed 4 years ago by zzz

  • Status changed from new to infoneeded_new

Eepsite links on console home page and summary bar fixed in 05d471fae810bd47bd70992b7ef56f1f84184a41 0.9.20-12. Returning ticket to OP as you implied there are other cases.

comment:5 Changed 4 years ago by djjeshk

  • Status changed from infoneeded_new to new

Another real problem about hardcoded tunnel id 0, steps to reproduce:

  1. Create a new client tunnel and specify dead outproxy address
  2. Delete preconfigured tunnel at /i2ptunnel/edit.jsp?tunnel=0
  3. Try to access some clearnet address until Outproxy Not Found appears.
  4. Click link after
    If you continue to have trouble you may want to edit your outproxy list
    

and not http proxy settings will appear (IRC tunnel settings appeared)

It is real problem for me. Theoretical problem is situation when message "there is hardcoded '4444', '7657', '6668', '7654' everywhere" needs a proof that something will break. Posting separate comment for each place is ineffective but better than nothing. Trac database bytes does not sits at my hard drive so no reason to stop posting similar issues.

comment:6 Changed 4 years ago by zzz

I'm not demanding a list, I'm just asking for help. Since you're the one with the problems, it's reasonable to ask you for details. Grepping for [0-9]* as suggested in the OP isn't an efficient way to look for issues. Snide comments about 'database bytes' doesn't help my attitude and won't get things fixed any sooner.

Last edited 4 years ago by zzz (previous) (diff)

comment:7 Changed 3 years ago by zzz

  • Milestone changed from undecided to 0.9.24
  • Resolution set to fixed
  • Status changed from new to closed

i2ptunnel http proxy error pages are now rewritten on-the-fly to fix up the hostname or ip and port, in 0.9.24. This addresses the issue in comment 5 above. Others links were fixed in 0.9.21 (see comment 4 above).

If there's any others I missed, please open a new ticket.

Note: See TracTickets for help on using tickets.