Opened 4 years ago

Closed 4 years ago

#1605 closed defect (not a bug)

Automatic restart several times a day since 0.9.20-8

Reported by: hummingbird Owned by:
Priority: minor Milestone: n/a
Component: router/general Version: 0.9.20
Keywords: Cc:
Parent Tickets:

Description

Automatic restart several times a day since 0.9.20-8 (or 0.9.20-6)

21/06/15 09:33:20 CRIT [P reader 4/4] net.i2p.router.Router : Thread ran out of memory, shutting down I2P
java.lang.OutOfMemoryError?: GC overhead limit exceeded

at java.util.regex.Matcher.<init>(Matcher.java:224)
at java.util.regex.Pattern.matcher(Pattern.java:1088)
at java.lang.String.replaceAll(String.java:2162)
at net.i2p.data.router.RouterAddress?.getIP(RouterAddress?.java:221)
at net.i2p.router.transport.udp.UDPTransport.getTargetAddress(UDPTransport.java:1724)
at net.i2p.router.transport.udp.UDPTransport.bid(UDPTransport.java:1656)
at net.i2p.router.transport.TransportManager?.getNextBid(TransportManager?.java:580)
at net.i2p.router.transport.GetBidsJob?.getBids(GetBidsJob?.java:67)
at net.i2p.router.transport.CommSystemFacadeImpl?.processMessage(CommSystemFacadeImpl?.java:152)
at net.i2p.router.OutNetMessagePool?.add(OutNetMessagePool?.java:49)
at net.i2p.router.tunnel.TunnelParticipant?.send(TunnelParticipant?.java:199)
at net.i2p.router.tunnel.TunnelParticipant?.dispatch(TunnelParticipant?.java:112)
at net.i2p.router.tunnel.TunnelDispatcher?.dispatch(TunnelDispatcher?.java:527)
at net.i2p.router.InNetMessagePool?.doShortCircuitTunnelData(InNetMessagePool?.java:326)
at net.i2p.router.InNetMessagePool?.shortCircuitTunnelData(InNetMessagePool?.java:311)
at net.i2p.router.InNetMessagePool?.add(InNetMessagePool?.java:180)
at net.i2p.router.transport.TransportManager?.messageReceived(TransportManager?.java:642)
at net.i2p.router.transport.TransportImpl?.messageReceived(TransportImpl?.java:497)
at net.i2p.router.transport.ntcp.NTCPConnection$ReadState?.receiveLastBlock(NTCPConnection.java:1542)
at net.i2p.router.transport.ntcp.NTCPConnection$ReadState?.receiveSubsequent(NTCPConnection.java:1500)
at net.i2p.router.transport.ntcp.NTCPConnection$ReadState?.receiveBlock(NTCPConnection.java:1450)
at net.i2p.router.transport.ntcp.NTCPConnection.recvUnencryptedI2NP(NTCPConnection.java:1275)
at net.i2p.router.transport.ntcp.NTCPConnection.recvEncryptedFast(NTCPConnection.java:1256)
at net.i2p.router.transport.ntcp.NTCPConnection.recvEncryptedI2NP(NTCPConnection.java:1186)
at net.i2p.router.transport.ntcp.Reader.processRead(Reader.java:180)
at net.i2p.router.transport.ntcp.Reader.access$400(Reader.java:21)
at net.i2p.router.transport.ntcp.Reader$Runner.run(Reader.java:120)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:107)

21/06/15 09:33:20 CRIT [P reader 4/4] net.i2p.router.Router : free mem: 14907816 total mem: 119537664
21/06/15 09:33:20 CRIT [P reader 4/4] net.i2p.router.Router : To prevent future shutdowns, increase wrapper.java.maxmemory in /home/icecube/i2p/wrapper.config
21/06/15 09:33:42 CRIT [P reader 4/4] net.i2p.router.Router : Starting final shutdown(10)
21/06/15 09:33:43 CRIT [leTimer2 2/4] net.i2p.util.SimpleTimer2 : SimpleTimer2: Timed task net.i2p.router.transport.OutboundMessageRegistry?$CleanupTask?@30c018f7 exited unexpectedly, please report
java.lang.OutOfMemoryError?: GC overhead limit exceeded
21/06/15 09:33:45 CRIT [mer 1nq8 1/4] net.i2p.util.SimpleTimer2 : Streaming Timer 1nq8: Timed task net.i2p.client.streaming.impl.MessageOutputStream?$Flusher@14988bf5 exited unexpectedly, please report
java.lang.OutOfMemoryError?: GC overhead limit exceeded
21/06/15 09:33:48 CRIT [leTimer2 2/4] net.i2p.util.SimpleTimer2 : SimpleTimer2: Timed task net.i2p.router.transport.udp.UDPTransport$ExpirePeerEvent?@db8caa1 exited unexpectedly, please report
java.lang.OutOfMemoryError?: GC overhead limit exceeded
21/06/15 09:33:49 WARN [e Jetty-2445] rg.eclipse.jetty.server.Server: EXCEPTION : javax.servlet.ServletException?: java.lang.OutOfMemoryError?: GC overhead limit exceeded
21/06/15 09:33:51 CRIT [leTimer2 6/4] net.i2p.util.SimpleTimer2 : SimpleTimer2: Timed task net.i2p.util.ByteCache?$Cleanup@18390633 exited unexpectedly, please report
java.lang.OutOfMemoryError?: GC overhead limit exceeded
21/06/15 09:33:51 CRIT [anager Reorg] router.peermanager.PeerManager?: Error evaluating profiles
java.lang.OutOfMemoryError?: GC overhead limit exceeded
21/06/15 09:33:57 ERROR [nal Reader 2] lient.impl.I2PSessionMuxedImpl: [shared clients #29813 OPEN]: Error occurred communicating with router: Router shutdown
net.i2p.client.I2PSessionException: Disconnect Message received

at net.i2p.client.impl.DisconnectMessageHandler?.handleMessage(DisconnectMessageHandler?.java:33)
at net.i2p.client.impl.I2PSessionImpl.messageReceived(I2PSessionImpl.java:914)
at net.i2p.internal.QueuedI2CPMessageReader$QueuedI2CPMessageReaderRunner.run2(QueuedI2CPMessageReader.java:56)
at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:162)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:107)

21/06/15 09:33:58 ERROR [P ACK sender] ter.transport.udp.PacketPusher?: No endpoint to send 73 byte pkt with 74.248.218.171:16778 msgType=42 markType=1
21/06/15 09:34:03 CRIT [P reader 4/4] net.i2p.router.Router : Shutdown(10) complete

I will edit /i2p/wrapper.config to change "wrapper.java.maxmemory=" from 128 to 256 (I had this setting before I reinstalled my OS some weeks ago).

Subtickets

Change History (3)

comment:1 Changed 4 years ago by zzz

  • Component changed from unspecified to router/general
  • Status changed from new to infoneeded_new

looks like a typical OOM, unrelated to -8, please report results after going back to 256

comment:2 Changed 4 years ago by hummingbird

  • Status changed from infoneeded_new to new

Ok, now this work nice with 256 MB of RAM.
Perhaps the issue was also related to my ISP that had issues for 3 days (disconnecting my modem). You can close this ticket.

comment:3 Changed 4 years ago by zzz

  • Milestone changed from undecided to n/a
  • Resolution set to not a bug
  • Status changed from new to closed
  • Type changed from task to defect

thanks

Note: See TracTickets for help on using tickets.