Opened 4 years ago

Closed 4 years ago

#1619 closed defect (fixed)

Error processing job [Update Reply Found for Kademlia Search] on thread 3: null

Reported by: dg Owned by: zzz
Priority: major Milestone: 0.9.21
Component: router/netdb Version: 0.9.20
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.9.20-15
Java version: Oracle Corporation 1.7.0_71 (OpenJDK Runtime Environment 1.7.0_71-b14)
Wrapper version: none
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: OpenBSD amd64 5.7
Processor: Core i7 (45nm) (corei)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: ISO646-US
Charset: US-ASCII
CRIT [JobQueue 4/4] net.i2p.router.JobQueueRunner : Error processing job [Update Reply Found for Kademlia Search] on thread 3: null
         java.lang.NullPointerException
         at net.i2p.router.tunnel.TunnelDispatcher.dispatchOutbound(TunnelDispatcher.java:641)
         at net.i2p.router.tunnel.TunnelDispatcher.dispatchOutbound(TunnelDispatcher.java:620)
         at net.i2p.router.networkdb.kademlia.SearchJob.sendLeaseSearch(SearchJob.java:472)
         at net.i2p.router.networkdb.kademlia.SearchJob.sendSearch(SearchJob.java:413)
         at net.i2p.router.networkdb.kademlia.SearchJob.continueSearch(SearchJob.java:327)
         at net.i2p.router.networkdb.kademlia.SearchJob.searchNext(SearchJob.java:235)
         at net.i2p.router.networkdb.kademlia.SearchUpdateReplyFoundJob.runJob(SearchUpdateReplyFoundJob.java:108)
         at net.i2p.router.JobQueueRunner.runCurrentJob(JobQueueRunner.java:134)
         at net.i2p.router.JobQueueRunner.run(JobQueueRunner.java:77)

Subtickets

Change History (1)

comment:1 Changed 4 years ago by zzz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in ef2cdd0de9ceb96abb29878e01fafc6994b99b0d 0.9.20-19-rc

Null error return was not checked. Root cause of null return not clear... perhaps SKM wasn't ready yet (startup or shutdown).

Note: See TracTickets for help on using tickets.