Opened 4 years ago

Closed 4 years ago

#1622 closed defect (not a bug)

Custom IP Not working

Reported by: ghere Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.20
Keywords: /confignet Cc:
Parent Tickets:

Description

I used secondary IP for "Externally reachable hostname or IP address" udp/tcp. My incomming traffic comming from my secondary IP but all outgoing traffic goes my primary ip (default routed ip by OS). That's normal?

Subtickets

Change History (1)

comment:1 Changed 4 years ago by zzz

  • Resolution set to not a bug
  • Status changed from new to closed

IP routing is indeed controlled by the OS. Having the incoming and outgoing directions take different routes (or, more correctly, different source IPs) will wreak havoc with SSU. But there's little or nothing we can do to detect it, much less do anything about it.

For best results, configure your OS-level routing to match your I2P configuration.

Note: See TracTickets for help on using tickets.