Opened 3 years ago

Closed 3 years ago

#1624 closed defect (fixed)

I2PControl plugin fails to start

Reported by: unknown11 Owned by:
Priority: major Milestone: 0.9.21
Component: apps/plugins Version: 0.9.20
Keywords: i2pcontrol Cc:
Parent Tickets:

Description

I've installed I2PControl plugin from itoopie.i2p

It does not work and shows this messages in logs:

7/30/15 12:19:01 AM CRIT [I2PControl ] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.i2pcontrol.I2PControlController

java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:62)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:107)
Caused by: java.lang.NullPointerException?
at net.i2p.i2pcontrol.I2PControlController.stop(I2PControlController.java:242)
at net.i2p.i2pcontrol.I2PControlController.main(I2PControlController.java:71)
... 7 more

7/30/15 12:18:51 AM CRIT [I2PControl ] uter.startup.LoadClientAppsJob?: Error starting up the client class net.i2p.i2pcontrol.I2PControlController

java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:62)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:107)
Caused by: java.lang.NullPointerException?
at sun.security.provider.JavaKeyStore?.engineStore(JavaKeyStore?.java:569)
at sun.security.provider.JavaKeyStore?$JKS.engineStore(JavaKeyStore?.java:55)
at java.security.KeyStore?.store(KeyStore?.java:1365)
at net.i2p.i2pcontrol.security.KeyStoreFactory?.writeCACertToKeyStore(KeyStoreFactory?.java:229)
at net.i2p.i2pcontrol.security.KeyStoreInitializer?.getKeyStore(KeyStoreInitializer?.java:29)
at net.i2p.i2pcontrol.security.SecurityManager?.<init>(SecurityManager?.java:78)
at net.i2p.i2pcontrol.security.SecurityManager?.getInstance(SecurityManager?.java:56)
at net.i2p.i2pcontrol.I2PControlController.main(I2PControlController.java:66)
... 7 more

7/30/15 12:18:48 AM CRIT [I2PControl ] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.i2pcontrol.I2PControlController

java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:62)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:107)
Caused by: java.lang.NullPointerException?
at net.i2p.i2pcontrol.I2PControlController.stop(I2PControlController.java:242)
at net.i2p.i2pcontrol.I2PControlController.main(I2PControlController.java:71)
... 7 more

Subtickets

#1625: Correct log markup for #1624defectclosed

Change History (3)

comment:1 Changed 3 years ago by unknown11

Add a subticket #1625.

comment:2 Changed 3 years ago by tuna

Pushed i2pcontrol 0.1.0.
Please verify this bug has been fixed.

comment:3 Changed 3 years ago by tuna

  • Milestone changed from undecided to 0.9.21
  • Resolution set to fixed
  • Status changed from new to closed

Verified as fixed.

Note: See TracTickets for help on using tickets.