Opened 4 years ago

Closed 4 years ago

#1625 closed defect (fixed)

Correct log markup for #1624

Reported by: unknown11 Owned by:
Priority: minor Milestone: undecided
Component: apps/plugins Version: 0.9.20
Keywords: I2PControl Cc:
Parent Tickets: #1624 Sensitive: no

Description

7/30/15 12:18:48 AM CRIT  [I2PControl  ] t.i2p.router.web.PluginStarter: Error starting up the client class net.i2p.i2pcontrol.I2PControlController
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at net.i2p.router.startup.LoadClientAppsJob$RunApp.run(LoadClientAppsJob.java:291)
	at java.lang.Thread.run(Thread.java:745)
	at net.i2p.util.I2PThread.run(I2PThread.java:107)
Caused by: java.lang.NullPointerException
	at net.i2p.i2pcontrol.I2PControlController.stop(I2PControlController.java:242)
	at net.i2p.i2pcontrol.I2PControlController.main(I2PControlController.java:71)
	... 7 more
7/30/15 12:18:51 AM CRIT  [I2PControl  ] uter.startup.LoadClientAppsJob: Error starting up the client class net.i2p.i2pcontrol.I2PControlController
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at net.i2p.router.startup.LoadClientAppsJob$RunApp.run(LoadClientAppsJob.java:291)
	at java.lang.Thread.run(Thread.java:745)
	at net.i2p.util.I2PThread.run(I2PThread.java:107)
Caused by: java.lang.NullPointerException
	at sun.security.provider.JavaKeyStore.engineStore(JavaKeyStore.java:569)
	at sun.security.provider.JavaKeyStore$JKS.engineStore(JavaKeyStore.java:55)
	at java.security.KeyStore.store(KeyStore.java:1365)
	at net.i2p.i2pcontrol.security.KeyStoreFactory.writeCACertToKeyStore(KeyStoreFactory.java:229)
	at net.i2p.i2pcontrol.security.KeyStoreInitializer.getKeyStore(KeyStoreInitializer.java:29)
	at net.i2p.i2pcontrol.security.SecurityManager.<init>(SecurityManager.java:78)
	at net.i2p.i2pcontrol.security.SecurityManager.getInstance(SecurityManager.java:56)
	at net.i2p.i2pcontrol.I2PControlController.main(I2PControlController.java:66)
	... 7 more
7/30/15 12:19:01 AM CRIT  [I2PControl  ] t.i2p.router.web.PluginStarter: Error starting up the client class net.i2p.i2pcontrol.I2PControlController
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:483)
	at net.i2p.router.startup.LoadClientAppsJob$RunApp.run(LoadClientAppsJob.java:291)
	at java.lang.Thread.run(Thread.java:745)
	at net.i2p.util.I2PThread.run(I2PThread.java:107)
Caused by: java.lang.NullPointerException
	at net.i2p.i2pcontrol.I2PControlController.stop(I2PControlController.java:242)
	at net.i2p.i2pcontrol.I2PControlController.main(I2PControlController.java:71)
	... 7 more
7/30/15 12:19:53 AM ^^^ 1 similar message omitted ^^^

Subtickets

Change History (1)

comment:1 Changed 4 years ago by tuna

Resolution: fixed
Status: newclosed

Verified as fixed.

Note: See TracTickets for help on using tickets.