Opened 4 years ago

Last modified 3 years ago

#1630 assigned defect

Bote fails to start at first run after update

Reported by: user Owned by: str4d
Priority: maintenance Milestone: 0.9.22
Component: apps/plugins Version: 0.9.21
Keywords: I2P-Bote Cc:
Parent Tickets: Sensitive: no

Description

After the update to 0.9.21, i2p-bote did not start.
Looking into the logs I see:

I2P version: 0.9.21-0-1ubuntu1
Java version: Oracle Corporation 1.7.0_79 (OpenJDK Runtime Environment 1.7.0_79-b14)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.13.0-39-lowlatency
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

ERROR[luginStarter] t.i2p.router.web.PluginStarter?: Failed to start plugin: i2pbote

java.lang.IllegalArgumentException?: Bad temp directory: /tmp/i2p-daemon/i2p-cFkskYum.tmp/jetty-work-i2pbote72985129
at org.eclipse.jetty.webapp.WebAppContext?.setTempDirectory(WebAppContext?.java:1119)
at net.i2p.router.web.WebAppStarter?.addWebApp(WebAppStarter?.java:101)
at net.i2p.router.web.WebAppStarter?.startWebApp(WebAppStarter?.java:57)
at net.i2p.router.web.PluginStarter?.startPlugin(PluginStarter?.java:380)
at net.i2p.router.web.PluginStarter?.startPlugins(PluginStarter?.java:211)
at net.i2p.router.web.PluginStarter?.run(PluginStarter?.java:87)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:115)

Trying to start it manually, gives the following error in the web console:
java.lang.IllegalArgumentException?: Bad temp directory: /tmp/i2p-daemon/i2p-cFkskYum.tmp/jetty-work-i2pbote776606184

I had that error before and then it was fixed by a router restart.
I don't remember well, but maybe last time I had it, it was also right after router update
Since this is the second time it occurrs it might be a bug with i2p and not just my computer being in the mood for getting on my nerves.

I ran -22-rc before and it started fine.

Also this time, a simple router restart fixed it.

Subtickets

Change History (5)

comment:1 Changed 4 years ago by killyourtv

Component: apps/pluginspackage/debian
Milestone: undecided0.9.22
Owner: set to killyourtv
Status: newaccepted

comment:2 Changed 4 years ago by killyourtv

May be apparmor related. (My rules may need some relaxing)

comment:3 Changed 4 years ago by user

But I have selected no, as reply to the AppArmor? question in dpkg-reconfigure i2p…

comment:4 Changed 3 years ago by zzz

Component: package/debianapps/plugins
Owner: changed from killyourtv to str4d
Status: acceptedassigned

comment:5 Changed 3 years ago by str4d

Migrated to https://github.com/i2p/i2p.i2p-bote/issues - I will close these tickets as things are resolved rather than right now, but please make future comments on GitHub?.

Note: See TracTickets for help on using tickets.