Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1639 closed defect (worksforme)

i2p firewalled if static ip

Reported by: noname_noname Owned by:
Priority: minor Milestone: 0.9.21
Component: router/general Version: 0.9.21
Keywords: raspberry, ip Cc:
Parent Tickets:

Description

Use raspberry pi 2.
When set up using static ip by ethernet (no matter, by /boot/ config or generic debian files), i2p status is being "firewalled". When set back to DHCP i2p works fine.

Subtickets

Change History (2)

comment:1 Changed 4 years ago by somewon

  • Resolution set to worksforme
  • Status changed from new to closed

comment:2 Changed 4 years ago by somewon

I suspect that the issue is port forwarding. Are you behind a router or any kind of NAT on your local network? It's very likely that I2P's port is being forwarded successfully via UPnP when the connection uses DHCP, but that something is off in the UPnP negotiation with a static IP address (UPnP is a bit notorious for buggy implementations).

What OS are you using, and what does the rest of your network look like? Are you using I2P's UPnP feature for port forwarding? Have you tried forwarding the port manually in your router's configuration?

Note: See TracTickets for help on using tickets.