Opened 4 years ago

Closed 4 years ago

#1692 closed defect (fixed)

v0.9.22-19 "net.i2p.data.i2cp.I2CPMessageException: Unable to write the message length or type"

Reported by: hummingbird Owned by: zzz
Priority: minor Milestone: 0.9.23
Component: router/general Version: 0.9.22
Keywords: Cc:
Parent Tickets:

Description

I see these red texts in my log.
Note: my ISP has often huge lag issues.

26/10/15 00:58:53 ERROR [CP Reader 15] ent.ClientMessageEventListener?: SendMessage? invalid session: [SessionId: 42593] current: []
26/10/15 00:58:53 4 similar messages omitted
26/10/15 00:58:53 ERROR [2CP Writer 1] .client.ClientConnectionRunner?: Error sending I2CP message to client
net.i2p.data.i2cp.I2CPMessageException: Unable to write the message length or type

at net.i2p.data.i2cp.MessageStatusMessage?.writeMessage(MessageStatusMessage?.java:334)
at net.i2p.router.client.ClientConnectionRunner?.writeMessage(ClientConnectionRunner?.java:927)
at net.i2p.router.client.ClientWriterRunner?.run(ClientWriterRunner?.java:70)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:115)

Caused by: net.i2p.data.DataFormatException?: Value is negative (-1)

at net.i2p.data.DataHelper?.writeLong(DataHelper?.java:692)
at net.i2p.data.i2cp.MessageStatusMessage?.writeMessage(MessageStatusMessage?.java:329)
... 4 more

26/10/15 00:58:53 ERROR [CP Reader 15] ent.ClientMessageEventListener?: SendMessage? invalid session: [SessionId: 42593] current: []
26/10/15 01:28:59 ERROR [CP Reader 16] ent.ClientMessageEventListener?: SendMessage? invalid session: [SessionId: 42593] current: []
26/10/15 01:28:59 ERROR [2CP Writer 2] .client.ClientConnectionRunner?: Error sending I2CP message to client
net.i2p.data.i2cp.I2CPMessageException: Unable to write the message length or type

at net.i2p.data.i2cp.MessageStatusMessage?.writeMessage(MessageStatusMessage?.java:334)
at net.i2p.router.client.ClientConnectionRunner?.writeMessage(ClientConnectionRunner?.java:927)
at net.i2p.router.client.ClientWriterRunner?.run(ClientWriterRunner?.java:70)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:115)

Caused by: net.i2p.data.DataFormatException?: Value is negative (-1)

at net.i2p.data.DataHelper?.writeLong(DataHelper?.java:692)
at net.i2p.data.i2cp.MessageStatusMessage?.writeMessage(MessageStatusMessage?.java:329)
... 4 more

26/10/15 06:35:41 INFO 3/4? b.kademlia.FloodfillMonitorJob?: Only 635 ff peers and we want 5000 so we are becoming floodfill

Subtickets

Change History (2)

comment:1 Changed 4 years ago by zzz

  • Component changed from unspecified to router/general
  • Milestone changed from undecided to 0.9.23
  • Status changed from new to accepted

_messageId is -1 at MessageStatusMessage? line 329.

Not set in ClientMessageEventListener? at line ~380

probably only affects external i2cp

comment:2 Changed 4 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed in 5d97a38c06eec982406fdb03063b568dc9edc607 0.9.22-20

Note: See TracTickets for help on using tickets.