Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1760 closed enhancement (wontfix)

merging seedless and neodatis

Reported by: anonymous maybe Owned by: sponge
Priority: minor Milestone: undecided
Component: apps/plugins Version: 0.9.24
Keywords: Cc:
Parent Tickets:

Description

i think it will be better idea if we merge both of seedless and neodatis , because if someone installed seedless then later going to install neodatis here is the problem he will have inside his logs:-

  • I2P Version and Running Environment

I2P version: 0.9.24-0-1~deb8u+1
Java version: Oracle Corporation 1.7.0_95 (OpenJDK Runtime Environment 1.7.0_95-b00)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 4.1.13-8.pvops.qubes.x86_64
Processor: Haswell (22nm) (corei)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

  • Critical Logs

2/8/16 7:12:44 AM CRIT [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)
Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
... 7 more

2/8/16 6:23:26 AM CRIT [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)
Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
... 7 more

  • Router Logs

File location: /home/user/.i2p/logs/log-router-1.txt

2/8/16 7:12:44 AM CRIT [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)
Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
... 7 more

2/8/16 6:23:26 AM CRIT [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
java.lang.reflect.InvocationTargetException?
at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)
Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
... 7 more

  • Service (Wrapper) Logs

2016/02/08 04:25:44 | CRIT [ShutdownHook?] net.i2p.router.Router : Graceful shutdown progress: No more tunnels, starting final shutdown
2016/02/08 04:25:44 | CRIT [ShutdownHook?] net.i2p.router.Router : Starting final shutdown(2)
2016/02/08 04:25:44 | CRIT [ShutdownHook?] net.i2p.router.Router : Shutdown(2) complete
2016/02/08 04:25:46 | <-- Wrapper Stopped
2016/02/08 05:04:11 | --> Wrapper Started as Daemon
2016/02/08 05:04:11 | Java Service Wrapper Community Edition 64-bit 3.5.25
2016/02/08 05:04:11 | Copyright (C) 1999-2014 Tanuki Software, Ltd. All Rights Reserved.
2016/02/08 05:04:11 | http://wrapper.tanukisoftware.com
2016/02/08 05:04:11 |
2016/02/08 05:04:12 | Launching a JVM...
2016/02/08 05:04:14 | WrapperManager?: Initializing...
2016/02/08 05:04:14 | Starting I2P 0.9.24-0-1~deb8u+1
2016/02/08 05:04:15 | INFO: Native CPUID library jcpuid-x86-linux loaded from file
2016/02/08 05:04:15 | INFO: Locally optimized native BigInteger? library loaded from file
2016/02/08 06:23:16 | INFO: 6 files extracted to /home/user/.i2p/plugins/02_seedless
2016/02/08 06:23:30 | CRIT [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
2016/02/08 06:23:30 | java.lang.reflect.InvocationTargetException?
2016/02/08 06:23:30 | at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
2016/02/08 06:23:30 | at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
2016/02/08 06:23:30 | at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
2016/02/08 06:23:30 | at java.lang.reflect.Method.invoke(Method.java:606)
2016/02/08 06:23:30 | at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
2016/02/08 06:23:30 | at java.lang.Thread.run(Thread.java:745)
2016/02/08 06:23:30 | at net.i2p.util.I2PThread.run(I2PThread.java:103)
2016/02/08 06:23:30 | Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
2016/02/08 06:23:30 | at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
2016/02/08 06:23:30 | ... 7 more
2016/02/08 07:12:49 | CRIT [.Main client] t.i2p.router.web.PluginStarter?: Error starting up the client class net.i2p.seedlesscoreclassincluder.Main
2016/02/08 07:12:49 | java.lang.reflect.InvocationTargetException?
2016/02/08 07:12:49 | at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
2016/02/08 07:12:49 | at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
2016/02/08 07:12:49 | at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
2016/02/08 07:12:49 | at java.lang.reflect.Method.invoke(Method.java:606)
2016/02/08 07:12:49 | at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:291)
2016/02/08 07:12:49 | at java.lang.Thread.run(Thread.java:745)
2016/02/08 07:12:49 | at net.i2p.util.I2PThread.run(I2PThread.java:103)
2016/02/08 07:12:49 | Caused by: java.lang.ClassNotFoundException?: Can't Add SeedlessCore?, NeoDatis? not found.
2016/02/08 07:12:49 | at net.i2p.seedlesscoreclassincluder.Main.main(Main.java:140)
2016/02/08 07:12:49 | ... 7 more

Subtickets

Change History (5)

comment:1 Changed 3 years ago by echelon

  • Owner set to sponge
  • Priority changed from critical to minor
  • Status changed from new to assigned
  • Type changed from defect to enhancement

forwarded to sponge, as thats sponge job

comment:2 Changed 3 years ago by zzz

He's refused to do this in the past, and he's not actively working on these plugins. It's not going to happen.

comment:3 Changed 3 years ago by anonymous maybe

but thats bad. i think there r only three solutions for this:-

1- merging them whether he accept that or not

2- withdrawn/remove neodatis from plugins

3- remove both of them (neodatis&seedless)

because "do nothing" is not an option. also add to this there is a real BUG over here so its like someone saying im not going to fix ? this shouldnt be happening inside an active project.

Last edited 3 years ago by anonymous maybe (previous) (diff)

comment:4 Changed 3 years ago by zzz

  • Resolution set to wontfix
  • Status changed from assigned to closed

Your expectations are far off from reality. Plugins are 3rd-party projects and may be experimental or abandoned. People come and go around here. You listing 3 options or trying to guilt us into it with the "active project" statement doesn't make it true.

I happen to agree with you that they should be combined. Sponge and I had several discussions about it back in the day. I lost. This was his vision and he implemented it.

As he hasn't touched seedless in 3 1/2 years, and he firmly believed in separate plugins, I'm confident it's not gonig to happen, as I said in comment 2 above. Closing so we can stop wasting time here.

There's nothing to 'remove', plugins are hosted on 3rd party sites.

comment:5 Changed 3 years ago by anonymous maybe

yeah i c , because i thought the plugins is also I2P responsibility. thnx for the clarification.

Note: See TracTickets for help on using tickets.