Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1761 closed defect (not a bug)

I2P gives yellow mark on idle state

Reported by: anonymous maybe Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.24
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

when i dont do any activity and leave the pc opened for about half day or so , when i get back i c yellow mark nearby "shared client" , so i wonder if this is normal or not? because i think it should be green?

no critical logs or so but here the important details:-

  • I2P Version and Running Environment

I2P version: 0.9.24-0-1~deb8u+1
Java version: Oracle Corporation 1.7.0_95 (OpenJDK Runtime Environment 1.7.0_95-b00)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 4.1.13-8.pvops.qubes.x86_64
Processor: Haswell (22nm) (corei)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

  • Service (Wrapper) Logs

File location: /home/user/.i2p/wrapper.log

2016/02/10 00:15:42 | —> Wrapper Started as Daemon
2016/02/10 00:15:42 | Java Service Wrapper Community Edition 64-bit 3.5.25
2016/02/10 00:15:42 | Copyright © 1999-2014 Tanuki Software, Ltd. All Rights Reserved.
2016/02/10 00:15:42 | http://wrapper.tanukisoftware.com
2016/02/10 00:15:42 |
2016/02/10 00:15:42 | Launching a JVM…
2016/02/10 00:15:42 | WrapperManager?: Initializing…
2016/02/10 00:15:42 | Starting I2P 0.9.24-0-1~deb8u+1
2016/02/10 00:15:42 | Setting up new user directory /home/user/.i2p
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/docroot
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/docroot/help
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_de.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_na.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_sv.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_nl.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_zh.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_ru.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_fr.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/pagetemplate.html
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/docroot/help/lib
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/eepsite.css
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/ir.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/de.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/cn.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/es.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/se.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/it.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/brown.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/jp.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/fr.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/itoopie.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/nl.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/ru.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/bg.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/h2bg.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/lib/us.png
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/help/index_es.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/favicon.ico
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/index.html
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/docroot/robots.txt
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/etc
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/etc/realm.properties
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/etc/webdefault.xml
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/jetty-rewrite.xml
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/cgi-bin
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/jetty-jmx.xml
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/jetty.xml
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/webapps
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/logs
2016/02/10 00:15:42 | Created /home/user/.i2p/eepsite/contexts
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/contexts/base-context.xml
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/contexts/cgi-context.xml
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/jetty-ssl.xml
2016/02/10 00:15:42 | Copied /usr/share/i2p/hosts.txt
2016/02/10 00:15:42 | Copied /usr/share/i2p/i2psnark.config
2016/02/10 00:15:42 | Copied /usr/share/i2p/i2ptunnel.config
2016/02/10 00:15:42 | Copied /usr/share/i2p/router.config
2016/02/10 00:15:42 | Copied /usr/share/i2p/systray.config
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/jetty.xml with modifications
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/jetty-ssl.xml with modifications
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/contexts/base-context.xml with modifications
2016/02/10 00:15:42 | Copied /usr/share/i2p/eepsite/contexts/cgi-context.xml with modifications
2016/02/10 00:15:42 | Copied /usr/share/i2p/clients.config with modifications
2016/02/10 00:15:42 | Successfully copied data files to new user directory /home/user/.i2p
2016/02/10 00:15:43 | INFO: Native CPUID library jcpuid-x86-linux loaded from file
2016/02/10 00:15:43 | INFO: Locally optimized native BigInteger? library loaded from file
2016/02/10 00:15:44 | Reseed start
2016/02/10 00:15:44 | Reseeding from https://user.mx24.eu/i2pseeds.su3
2016/02/10 00:15:45 | INFO: Addressbook directory addressbook created
2016/02/10 00:15:46 | INFO: 77 files extracted to /tmp/i2p-GhxsXzlU.tmp/reseeds-250909569
2016/02/10 00:15:46 | Reseed got 77 router infos from https://user.mx24.eu/i2pseeds.su3 with 0 errors
2016/02/10 00:15:46 | Reseeding from https://reseed.i2p.vzaws.com:8443/i2pseeds.su3
2016/02/10 00:15:48 | INFO: 75 files extracted to /tmp/i2p-GhxsXzlU.tmp/reseeds-938246995
2016/02/10 00:15:48 | Reseed got 75 router infos from https://reseed.i2p.vzaws.com:8443/i2pseeds.su3 with 0 errors
2016/02/10 00:15:48 | Reseed complete, 152 received
2016/02/10 01:34:01 | CRIT [ShutdownHook?] net.i2p.router.Router : Restarting after a brief delay
2016/02/10 01:34:03 | CRIT [ShutdownHook?] net.i2p.router.Router : Starting final shutdown(4)
2016/02/10 01:34:03 | CRIT [ShutdownHook?] net.i2p.router.Router : Shutdown(4) complete
2016/02/10 01:34:06 | on_exit trigger matched. Restarting the JVM. (Exit code: 4)
2016/02/10 01:34:20 | Launching a JVM…
2016/02/10 01:34:20 | WrapperManager?: Initializing…
2016/02/10 01:34:21 | Starting I2P 0.9.24-0-1~deb8u+1
2016/02/10 01:34:21 | INFO: Native CPUID library jcpuid-x86-linux loaded from file
2016/02/10 01:34:21 | INFO: Locally optimized native BigInteger? library loaded from file

Subtickets

Attachments (1)

i2pidle.png (321.6 KB) - added by anonymous maybe 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by anonymous maybe

Attachment: i2pidle.png added

comment:1 Changed 4 years ago by Eche|on

Resolution: not a bug
Status: newclosed

Hi!

Yellow marks the tunnel idle state - aka waiting to be used.
Green is active and in action, red is not active, not idle, broken.
As I2P uses lots of ressources, a hidden service go into idle state after some time with no activity and reduce the usage of ressources. If it see some activity again, it builts up more tunnels and gets green again.
So all fine.

comment:2 Changed 4 years ago by anonymous maybe

aha i c , but just i want to ask:- isnt this considered a bad thing inside I2P system to have this feature ?

because this will reduce the number of connection points of I2P = which mean its adding loads on the active user , reduce the anonymity by reducing the points number.

or maybe im getting it wrong , but that is what im Imagening from this scenario.

Last edited 4 years ago by anonymous maybe (previous) (diff)

comment:3 Changed 4 years ago by Eche|on

No real harm done, it reduces the number of tunnels while they are not used. Why keep 2,3,4 or more tunnels open (and do the full crypto on it) while it is not in use and needed?
As it is only for clients, there is no change for servers. Clients are usually short living destinations and not really a target of a leaseset/server attack, as the leasesets are not distributed into the floodfill DB.

Note: See TracTickets for help on using tickets.