Opened 3 years ago

Closed 3 years ago

#1765 closed defect (wontfix)

I2P console shutdown doesnt match inside system shutdown

Reported by: anonymous maybe Owned by: kytv
Priority: major Milestone: undecided
Component: installer Version: 0.9.24
Keywords: Cc:
Parent Tickets:

Description

i shutdowned I2P from the console page , but in the system it is still running ? which is weird.

to reproduce this , go to terminal and type

i2prouter install

then choose "yes" then "yes" and then restart the system

now i2p should run automatically , let it has the enough to get green. then shutdown it by pressing "Shutdown"

after its completely shutdowned lastly go to the terminal and type

i2prouter status

still running??

but in fact the I2P Router Console is not working !!!

so in order to make I2P works again , u should restart it

i2prouter restart

then it will work again.

Subtickets

Attachments (1)

traci2p.png (59.2 KB) - added by anonymous maybe 3 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 3 years ago by zzz

  • Status changed from new to infoneeded_new

I can't begin to follow this or what you're trying to do.

But after 6 tickets in 24 hours, please start following the rules and add full version information from the top of the /logs page in the console.

Changed 3 years ago by anonymous maybe

comment:2 Changed 3 years ago by anonymous maybe

  • Status changed from infoneeded_new to new

c the attachment photo , and i dunno if the logs r useful or not. but here r they from my current active i2p:-

I2P version: 0.9.24-0-1~deb8u+1
Java version: Oracle Corporation 1.7.0_95 (OpenJDK Runtime Environment 1.7.0_95-b00)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 4.1.13-8.pvops.qubes.x86_64
Processor: Haswell (22nm) (corei)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: UTF-8
Charset: UTF-8

Last edited 3 years ago by anonymous maybe (previous) (diff)

comment:3 Changed 3 years ago by zzz

  • Component changed from apps/console to installer
  • Owner set to kytv
  • Status changed from new to assigned

comment:4 Changed 3 years ago by zzz

  • Resolution set to wontfix
  • Status changed from assigned to closed

So, apparently the complaint is that the console stops before 'i2prouter status' reports stopped. But that's by design, the console is just one subsystem, there's lots more to be stopped before shutdown is complete. There's no way to perfectly synchronize the two. On some platforms with slow storage (e.g. Rasp Pi) the final shutdown can take several minutes while state is being saved.

Note: See TracTickets for help on using tickets.