Opened 4 years ago

Closed 3 years ago

#1769 closed defect (fixed)

AM ERROR [Mv3Handler 1] net.i2p.sam.SAMv3Handler : SEND failed

Reported by: Eche|on Owned by: zzz
Priority: critical Milestone: 0.9.25
Component: apps/SAM Version: 0.9.24
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

2/14/16 11:10:11 AM ERROR [Mv3Handler 1] net.i2p.sam.SAMv3Handler : SEND failed
2/14/16 11:10:11 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: Memory: 82.43MB / 1.33GB
2/14/16 11:10:11 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: Outbound send rate: 111.31KBps
2/14/16 11:10:11 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: 1 minute send processing time: 356ms
2/14/16 11:10:11 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: Participating tunnel count: 86
2/14/16 11:10:11 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: Job lag: 0
2/14/16 11:10:11 AM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: Ready and waiting jobs: 0
2/14/16 11:10:11 AM ERROR [uterWatchdog] client.ClientManagerFacadeImpl?: Client v48xfu has a leaseSet that expired 9h

0.9.24-4
using iMule

and A lot more…
6 11:10:11 AM ↓↓↓ 360 similar messages omitted ↓↓↓
2/14/16 11:09:54 AM ↓↓↓ 606 similar messages omitted ↓↓↓
2/14/16 11:09:25 AM ↓↓↓ 271 similar messages omitted ↓↓↓

Subtickets

Change History (6)

comment:1 Changed 4 years ago by zzz

Milestone: undecided0.9.25
Owner: changed from mkvore to zzz
Status: newaccepted

possibly a SAM v3.3 bug, #1768 related, to be investigated

comment:2 Changed 4 years ago by hummingbird

Same issue for me (v0.9.24-5), I have lots of logs containing "xxx similar messages omitted" (ie: http://pastethis.i2p/show/10068/ ).

comment:3 Changed 4 years ago by hummingbird

Note: once downgraded to v0.9.24-1 the log becomes very quiet (no more "xxx similar messages omitted").

comment:4 Changed 4 years ago by zzz

The error log was completely bogus. When I refactored SAMv1Handler I made a typo and it was logging and error on datagram send success, not failure. Fixed in 0.9.24-6.

Since sam sends a LOT of datagrams, it really clogged up the error log. It's possible that things got locked up waiting on the log queue to clear out, and the typo is the root cause of the whole thing.

Or, there may be another problem causing the lockup.

Leaving ticket open for testing of -6 and further investigation.

comment:5 Changed 4 years ago by hummingbird

Uptime 14 H : log is OK.

comment:6 Changed 3 years ago by zzz

Resolution: fixed
Status: acceptedclosed

Closing as fixed. #1768 appears to be unrelated.

Note: See TracTickets for help on using tickets.