Opened 3 years ago

Closed 3 years ago

#1771 closed defect (not a bug)

noscript default setup needs modifications to work well with i2p

Reported by: anonymous maybe Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.24
Keywords: Cc:
Parent Tickets:

Description

there r some conflicts between I2P and NoScript?

1- if someone installed noscript inside his iceweasel/firefox , noscript comes pre-configured with ABE working inside it. and ABE by default is denying 'local connections'.

this is not a solvable problem from I2P side (i think) , so the best thing is to document this issue for new-users who will install noscript and using it with I2P. because the user should disable ABE in order to make links functions well. (check out the attachments)

2- noscript updated itself automatically so as iceweasel today , the strange thing i dont allow outproxy to clearnet nor i have disabled I2P proxy configurations inside iceweasel, tho noscript website&forum is working ?!?! which is weird. i wonder if u guys put noscript in I2P white-list or something is strange.

logs:-

I2P version: 0.9.24-0-1~deb8u+1
Java version: Oracle Corporation 1.7.0_95 (OpenJDK Runtime Environment 1.7.0_95-b00)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 4.1.13-8.pvops.qubes.x86_64
Processor: Haswell (22nm) (corei)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

Subtickets

Attachments (4)

ABEi2p.png (109.9 KB) - added by anonymous maybe 3 years ago.
ABEi2p2.png (43.5 KB) - added by anonymous maybe 3 years ago.
ABE3i2p3.png (49.1 KB) - added by anonymous maybe 3 years ago.
noscriptwebsiteworking.png (213.3 KB) - added by anonymous maybe 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by anonymous maybe

Changed 3 years ago by anonymous maybe

Changed 3 years ago by anonymous maybe

Changed 3 years ago by anonymous maybe

comment:1 Changed 3 years ago by echelon

  • Resolution set to not a bug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.