Opened 3 years ago

Closed 3 years ago

#1773 closed defect (not a bug)

Can't connect to anywhere

Reported by: caen Owned by:
Priority: minor Milestone: undecided
Component: unspecified Version: 0.9.24
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

iptables -L are empty. i2p under the same provider with other machines runs well. ipv6 disabled by systemd means.

Router console says

"Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, retrying in 20 seconds
Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, retrying in 20 seconds
Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, retrying in 20 seconds"

And so repeatedly, infinitely.
Browser by the way infinitely waits for pages loading, it seems without even timeout.

Machine:
I2P version: 0.9.24-0
Java version: Oracle Corporation 1.7.0_91 (OpenJDK Runtime Environment 1.7.0_91-b02)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux i386 3.16.0-4-686-pae
Processor: Core 2 (Conroe) (core2)
Jbigi: Locally optimized library libjbigi-linux-core2.so loaded from file
Encoding: UTF-8
Charset: UTF-8

Log contain this:

2/23/16 12:08:03 PM CRIT [ent Runner 6] .i2ptunnel.I2PTunnelClientBase: Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, giving up

net.i2p.client.I2PSessionException: [CLOSED shared clients]: Cannot connect to the router on [internal connection]:0
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:682)
at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:459)
at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:240)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.getDefaultOptions(I2PTunnelHTTPClient.java:293)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.clientConnectionRun(I2PTunnelHTTPClient.java:1198)
at net.i2p.i2ptunnel.I2PTunnelClientBase$BlockingRunner?.run(I2PTunnelClientBase.java:804)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:649)
… 8 more

2/23/16 12:04:50 PM CRIT [ent Runner 5] .i2ptunnel.I2PTunnelClientBase: Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, giving up

net.i2p.client.I2PSessionException: [CLOSED shared clients]: Cannot connect to the router on [internal connection]:0
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:682)
at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:459)
at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:240)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.getDefaultOptions(I2PTunnelHTTPClient.java:293)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.clientConnectionRun(I2PTunnelHTTPClient.java:1198)
at net.i2p.i2ptunnel.I2PTunnelClientBase$BlockingRunner?.run(I2PTunnelClientBase.java:804)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:649)
… 8 more

2/23/16 12:01:35 PM CRIT [ent Runner 4] .i2ptunnel.I2PTunnelClientBase: Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, giving up

net.i2p.client.I2PSessionException: [CLOSED shared clients]: Cannot connect to the router on [internal connection]:0
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:682)
at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:459)
at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:240)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.getDefaultOptions(I2PTunnelHTTPClient.java:293)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.clientConnectionRun(I2PTunnelHTTPClient.java:1198)
at net.i2p.i2ptunnel.I2PTunnelClientBase$BlockingRunner?.run(I2PTunnelClientBase.java:804)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:649)
… 8 more

2/23/16 12:00:14 PM CRIT [ent Runner 3] .i2ptunnel.I2PTunnelClientBase: Unable to connect to the router at 127.0.0.1:7654 and build tunnels for the client, giving up

net.i2p.client.I2PSessionException: [CLOSED shared clients]: Cannot connect to the router on [internal connection]:0
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:682)
at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:459)
at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:240)
at net.i2p.i2ptunnel.I2PTunnelHTTPClient.clientConnectionRun(I2PTunnelHTTPClient.java:1089)
at net.i2p.i2ptunnel.I2PTunnelClientBase$BlockingRunner?.run(I2PTunnelClientBase.java:804)
at java.util.concurrent.ThreadPoolExecutor?.runWorker(ThreadPoolExecutor?.java:1145)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:649)
… 7 more

2/23/16 11:57:26 AM ↓↓↓ 1 similar message omitted ↓↓↓

Subtickets

#1774: successfuly fixedclosed

Change History (2)

comment:1 Changed 3 years ago by caen

Add a subticket #1774.

comment:2 Changed 3 years ago by zzz

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.