Opened 4 years ago

Closed 3 years ago

#1776 closed defect (fixed)

Ability to reach eepsites degrades over time, returns when restarted.

Reported by: YesYesYes well maybe Owned by: zzz
Priority: major Milestone: 0.9.26
Component: api/utils Version: 0.9.25
Keywords: I2P service degrades, can't reach eepsites, I2PSnark status indicator error Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.9.24-0
Java version: Oracle Corporation 1.7.0_80 (Java™ SE Runtime Environment 1.7.0_80-b15)
Wrapper version: none
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows XP x86 5.1
Processor (athlon64)
Jbigi: Locally optimized library jbigi-windows-athlon64.dll loaded from file

The ability to reach eepsites degrades over time, returns when restarted. I'm not the only one with this problem. What happens is that over ten to twelve hours the ability to reach eepsites degrades or ends. If you shut everything off, not the computer OS just I2P, and restart you can immediately then go to eepsites that you were not able to before.

This may be a hard problem to fix.(understatement :) ) I notice that when floodfill is turned on in my log that the ability to get to the eepsites comes back. Therefore you being at the center of things you are probably in the state of always having floodfill on so you don't see this.

Some indicators that this problem is present is displayed in I2PSnark. If you look at the indicators "sort by status" on the far left hand side you can see a visual indicator of the level of degradation of service. Specifically. When the service has degraded then the status indication will no longer show peers or no peers. It will show a triangle with an exclamation point in it and say "tracker error:0/0peers"

Of course it can't be cut and dry because the torrents that are currently being downloaded show the status indicator correctly. It also seems, I think(don't hold me 100% to this), that I2PSnark can start up torrents and download them even though it shows the error status earlier.

There's also seems to degradation of the speed of downloading after the elapsed time reaches somewhere around 10 to 12 hours and the other indicators I mentioned start.

The errors don't start all at once. Sometimes only some of the downloading torrents will show error but eventually most all will show error over time.

Here's a post about this that someone posted and I added too.

http://forum.i2p/viewtopic.php?t=11676

It would make sense that the status indicator would show bad if the links too the websites were bad as they would not be able to reach them. I'm assuming, yes I know I shouldn't, that the continuation of torrent downloading is going on because of DHT or some other trackerless means and that is why torrents keep downloading. I do have seedless plug-in running also.

To clarify. When the status indicators change from error to normal status on I2PSnark I can look in the log and see that floodfill has been enabled. Restarting I2P always clears the problem up. Longer run times seem to degrade torrent download speed. When the status indicator shows error severe degradation occurs in the ability to reach eepsites. This includes the forums.

Subtickets

Change History (11)

comment:1 Changed 4 years ago by zzz

Component: router/transportrouter/general

Are there any indications in the router console summary bar that there is a problem?
Tunnels with yellow stars, job lag or message delay warnings?
How many torrents are you running at once?
Does disabling seedless fix the problem?
Are your bandwidth limit settings (both for the router and i2psnark) sensible?

comment:2 Changed 4 years ago by hummingbird

I think I just had the issue (could not reach forum.i2p for 3 hours, while it was up for others users). After restarting the router, forum.i2p is OK again.

v0.9.24-6, uptime: 41 hours

  • Are there any indications in the router console summary bar that there is a problem? [ ] Yes [x] No
  • Tunnels with yellow stars, job lag or message delay warnings? [ ] Yes [x] No
  • How many torrents are you running at once? : 7 (complete)
  • Does disabling seedless fix the problem? : [ ] Yes [x] No (after stopping it)
  • Are your bandwidth limit settings (both for the router and i2psnark) sensible? : what mean sensible ? Bandwith use is 70% of allowed.

comment:3 Changed 4 years ago by hummingbird

Same kind of issue: can't reach "forum.i2p" since 6 hours (tried 20 times), others users can.

v0.9.24-10, uptime: 18 hours

  • Are there any indications in the router console summary bar that there is a problem? [ ] Yes [x] No
  • Tunnels with yellow stars, job lag or message delay warnings? [ ] Yes [x] No
  • How many torrents are you running at once? : 7 (complete), 1 is uploading
  • Does disabling seedless fix the problem? : already tested previously
  • Are your bandwidth limit settings (both for the router and i2psnark) sensible? : what mean sensible ? Bandwith use is 90% of allowed. Note: after increasing upload bandwidth by 25%, issue is the same.
Last edited 4 years ago by hummingbird (previous) (diff)

comment:5 Changed 3 years ago by zzz

Status: newopen

So it doesn't seem to be a problem with the router as a whole… or is it?

I would think that it is related to some problem with close-on-idle HTTP client proxy tunnel… is close-on-idle enabled?

However, OP describes snark problems as well. Snark does not use the HTTP proxy tunnel. Unfortunately the OP has not answered my questions. Enabling floodfill does make you more 'popular', but also more congested. If floodfill fixes things, then the problem is not congestion, but lack of integration.

It isn't clear that OP and hummingbird's issues are identical or have the same cause.

I don't have any ideas at all. The best I can ask is to get familiar with the 'typical' stats in the summary bar (firewalled or not, active peers, known peers, bandwidth, number of participating tunnels, job lag, message delay, backlog) and compare them to the values when things don't work.

maybe then we can at least figure out if it's a router problem or a http proxy/i2ptunnel issue.

comment:6 Changed 3 years ago by zzz

Component: router/generalapi/utils
Milestone: undecided0.9.26

Found a nasty timer bug that's triggered by a backwards clock shift in the OS. Hard to say for sure if it's the root cause for this, since timers are everywhere. My symptoms were very low participating tunnels, and local eepsite became unreachable. Testing fix now.

comment:7 Changed 3 years ago by zzz

Also, all the graphs on the /graphs page are blank (NaN) which is a sure sign that the timers aren't running correctly.

comment:8 Changed 3 years ago by zzz

Status: opentesting

comment:9 Changed 3 years ago by hummingbird

I had some clock shift issues when running I2P the last 2 weeks, maybe it is related.

Note: with v0.9.25-8, uptime: 43 hours, all seems still OK.

Version 1, edited 3 years ago by hummingbird (previous) (next) (diff)

comment:10 Changed 3 years ago by Eche|on

ok, any response? For me the issues are gone with latest mtn builts.

comment:11 Changed 3 years ago by zzz

Resolution: fixed
Status: testingclosed
Note: See TracTickets for help on using tickets.