Opened 4 years ago

Closed 4 years ago

#1778 closed defect (fixed)

[CLOSED SAM TCP Client]: Failed to build tunnels

Reported by: hummingbird Owned by:
Priority: minor Milestone: 0.9.26
Component: router/general Version: 0.9.24
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I don't know if this is a real issue :

03/03/16 16:40:43 CRIT [l Reader 363] 2p.router.client.ClientManager?: Client attempted to register duplicate destination 426XISVkue8rC-lTt7yu1TpaNsOKTNKC~u7HSoAcBn0=
03/03/16 16:40:43 ERROR [l Reader 363] ent.ClientMessageEventListener?: Session establish failed: code = 3
03/03/16 16:40:43 ERROR [l Reader 363] .client.ClientConnectionRunner?: Disconnecting the client - duplicate destination
03/03/16 16:40:43 ERROR [l Reader 364] lient.impl.I2PSessionMuxedImpl: [GOTDATE SAM TCP Client]: Error occurred communicating with router: duplicate destination
net.i2p.client.I2PSessionException: Disconnect Message received

at net.i2p.client.impl.DisconnectMessageHandler?.handleMessage(DisconnectMessageHandler?.java:33)
at net.i2p.client.impl.I2PSessionImpl.messageReceived(I2PSessionImpl.java:916)
at net.i2p.internal.QueuedI2CPMessageReader$QueuedI2CPMessageReaderRunner.run2(QueuedI2CPMessageReader.java:56)
at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:164)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)

03/03/16 16:45:45 ERROR [Mv1Handler 2] net.i2p.sam.SAMv1Handler : Unexpected SAM error
net.i2p.sam.SAMException: Error creating I2PSocketManager: [CLOSED SAM TCP Client]: Failed to build tunnels

at net.i2p.sam.SAMStreamSession.<init>(SAMStreamSession.java:171)
at net.i2p.sam.SAMStreamSession.<init>(SAMStreamSession.java:97)
at net.i2p.sam.SAMv1Handler.newSAMStreamSession(SAMv1Handler.java:331)
at net.i2p.sam.SAMv1Handler.execSessionMessage(SAMv1Handler.java:295)
at net.i2p.sam.SAMv1Handler.handle(SAMv1Handler.java:171)
at net.i2p.sam.SAMHandler.run(SAMHandler.java:210)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)

Caused by: net.i2p.client.I2PSessionException: [CLOSED SAM TCP Client]: Failed to build tunnels

at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:691)
at net.i2p.sam.SAMStreamSession.<init>(SAMStreamSession.java:169)
… 7 more

Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.

at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:649)
… 8 more

I was running several applications. Perhaps the one involved is PyBitmessage?-I2P (http://i2pwiki.i2p/index.php?title=PyBitmessage-I2P).

I2P version: 0.9.24-10-rc
Java version: Oracle Corporation 1.7.0_95 (OpenJDK Runtime Environment 1.7.0_95-b00)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64

Subtickets

Change History (2)

comment:1 Changed 4 years ago by hummingbird

Same kind of log when launching or running PyBitmessage?-I2P v0.2.0

06/03/16 09:57:45 ERROR [v1Handler 44] net.i2p.sam.SAMv1Handler : Unexpected SAM error

net.i2p.sam.SAMException: Error creating I2PSocketManager: [CLOSED SAM TCP Client]: Failed to build tunnels
at net.i2p.sam.SAMStreamSession.<init>(SAMStreamSession.java:171)
at net.i2p.sam.SAMStreamSession.<init>(SAMStreamSession.java:97)
at net.i2p.sam.SAMv1Handler.newSAMStreamSession(SAMv1Handler.java:331)
at net.i2p.sam.SAMv1Handler.execSessionMessage(SAMv1Handler.java:295)
at net.i2p.sam.SAMv1Handler.handle(SAMv1Handler.java:171)
at net.i2p.sam.SAMHandler.run(SAMHandler.java:210)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)
Caused by: net.i2p.client.I2PSessionException: [CLOSED SAM TCP Client]: Failed to build tunnels
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:691)
at net.i2p.sam.SAMStreamSession.<init>(SAMStreamSession.java:169)
… 7 more
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:649)
… 8 more

06/03/16 09:52:44 ERROR [Reader 25190] lient.impl.I2PSessionMuxedImpl: [GOTDATE SAM TCP Client]: Error occurred communicating with router: duplicate destination

net.i2p.client.I2PSessionException: Disconnect Message received
at net.i2p.client.impl.DisconnectMessageHandler?.handleMessage(DisconnectMessageHandler?.java:33)
at net.i2p.client.impl.I2PSessionImpl.messageReceived(I2PSessionImpl.java:916)
at net.i2p.internal.QueuedI2CPMessageReader$QueuedI2CPMessageReaderRunner.run2(QueuedI2CPMessageReader.java:56)
at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:164)
at java.lang.Thread.run(Thread.java:745)
at net.i2p.util.I2PThread.run(I2PThread.java:103)

06/03/16 09:52:44 ERROR [Reader 25189] .client.ClientConnectionRunner?: Disconnecting the client - duplicate destination
06/03/16 09:52:44 ERROR [Reader 25189] ent.ClientMessageEventListener?: Session establish failed: code = 3
06/03/16 09:52:44 CRIT [Reader 25189] 2p.router.client.ClientManager?: Client attempted to register duplicate destination 426XISVkue8rC-lTt7yu1TpaNsOKTNKC~u7HSoAcBn0=
06/03/16 07:32:49 ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog?: Memory: 88,59MB / 171,00MB

comment:2 Changed 4 years ago by zzz

Milestone: undecided0.9.26
Resolution: fixed
Status: newclosed

The 'failure to build tunnels' is a fairly typical error when a router is very busy or is not well-integrated, so the log message that it is 'unexpected' is misleading. The watchdog error, although it was 2 ½ hours before the SAM errors, is indicative of an overloaded router.

The duplicate destination problem can be caused by a SAM client not handling errors well and retrying, or perhaps retrying too quickly. You said you were running several apps, but you didn't say if there was more than one SAM app, or if PyBitMessage? was it.

In 6b8b3f22db29751421c7d857a3723dfbaaddbf58 to be 0.9.25-9 I've removed the 'unexpected' terminology in the logs.

There's not a lot more here to go on. If it recurs, and you can narrow it down to a single SAM client app (PyBitMessage??), you could perhaps discuss it with the maintainer of that app. While the errors aren't particularly helpful, they do indicate an overloaded router resulting in tunnel build failure. Closing as 'fixed' since I did change something, but not much of a bug here, at least on our side.

Note: See TracTickets for help on using tickets.