Opened 5 years ago

Closed 5 years ago

#1806 closed defect (not a bug)

0.9.26 Debian fails dependencies

Reported by: Xeyed1 Owned by:
Priority: blocker Milestone: undecided
Component: installer Version: 0.9.26
Keywords: Debian Jessie 0.9.26 Cc:
Parent Tickets: Sensitive: no


I searched for tickets with 0.9.26 but did not see any relating to this. Hence the new ticket.

Synaptic on Debian Jessie fails to update from 0.9.25 to 0.9.26

Could not mark dependencies:


Depends: libgetopt-java but it is not installable
Depends: libjetty8-java but it is not installable
Depends: glassfish-javaee but it is not installable

It also failed to upgrade libservlet2.5-java automatically to libservlet3.0-java but I was able to do that manually.

I hope this ticket was filled in correctly. I don't do much on Trac so let me know if something could have been filled in better.



#1807: forgot to paste log into ticket #1806closed

Change History (8)

comment:1 Changed 5 years ago by Xeyed1

Add a subticket #1807.

comment:2 Changed 5 years ago by Eche|on


Hm, my debian shows:

apt-cache policy libgetopt-java

Installiert: (keine)
Installationskandidat: 1.0.14+dfsg-2

1.0.14+dfsg-3 0

300 sid/main amd64 Packages

1.0.14+dfsg-2 0

500 jessie/main amd64 Packages

1.0.13-4 0

401 wheezy/main amd64 Packages

At least for the last three release it is available. Even in main. Why do you not find it?


Last edited 5 years ago by Eche|on (previous) (diff)

comment:3 Changed 5 years ago by zzz

Status: newinfoneeded_new

From #1807. You now have comment permissions.

I2P version: 0.9.25-0-1~deb8u+1
Java version: Oracle Corporation 1.7.0_101 (OpenJDK Runtime Environment 1.7.0_101-b00)
Wrapper version: 3.5.25
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux amd64 3.16.0-4-amd64
Processor: Athlon 64 X2/Sempron X2/Athlon Neo X2 (Brisbane/Huron?, 65 nm) (athlon64)
Jbigi: Locally optimized native BigInteger? library loaded from file
Encoding: UTF-8
Charset: UTF-8

comment:4 Changed 5 years ago by zzz

Yes, in 0.9.26 we added dependencies on all 3 of those packages.

But in a simple package search, e.g. for libgetopt-java, you can see it's there:

so I don't understand what's going on here.

comment:5 Changed 5 years ago by Xeyed1

Status: infoneeded_newnew

I did my searching from within synaptic. Using synaptic's search for:




I received no found packages which is why synaptic was saying that they were not installable

Synaptic found libservlet with v2.5, 3.0, and 3.1 available. v2.5 was installed and some other package was holding back from upgrading to 3.0. Not sure if i2p would have found libservlet3.1 acceptable or not. Once the other packages install I could try v3.1 and see if it is acceptable.

If it v3.1 is acceptable it would be nice if i2p would ask for v3.0+ but that may be best reserved for another ticket.

I will see if I can find what is holding libservlet at 2.5 and try and raise the issue with that package maintainer.


comment:6 Changed 5 years ago by Xeyed1

I searched packages/ for libgetopt, libjetty, and glassfish. All three were there in Jessie. I tried to install from the terminal and got:

$sudo apt-get upgrade

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages have been kept back:


Will keep checking and see what I can find.


comment:7 Changed 5 years ago by Xeyed1

I think you can mark this closed. sites do not list the 3 new packages required and install failed even after the following attempt did succeed.

I opened a jessie virtual machine that had for repostitories and all packages were found and installed properly using synaptic.

Sorry for the unnecessary excitement.


comment:8 Changed 5 years ago by zzz

Resolution: not a bug
Status: newclosed

Thanks for the fast response. Let us know if you have any other problems.

Note: See TracTickets for help on using tickets.