Opened 3 years ago

Closed 3 years ago

#1811 closed defect (worksforme)

Fedora 24 Network: ERR-No Active Peers, Check Network Connection and Firewall

Reported by: notrix Owned by:
Priority: minor Milestone: undecided
Component: router/general Version: 0.9.26
Keywords: fedora Cc:
Parent Tickets: Sensitive: no

Description

Can't get i2p to work on Fedora 24.

It was working fine on the same machine and same router, with Debian Jessie, so it's probably something to do with the OS. Router port forwarding as well as Fedora's firewall-config are already done (otherwise network would not be OK, see below)

Network is Testing a bit longer than usual, then goes OK and stays that way for a while (30 minutes or more). After that it goes yellow again and shows the error in the description. No eepsites ever load.

Peers section from sidebar, while Network is still showing OK:

Active:	1 / 1
Fast:	12
High capacity:	31
Integrated:	58
Known:	111

Active goes down to 0/1 or 0/0 later on, but it never goes above 1/1.

i2p was built from git master, commit number 896af2c5d2c.
Btw I didn't put bouncycastle jar in lib this time, because there was no warning. Is that still necessary?

log message:

7/1/16 7:08:35 PM ERROR [.postman.i2p] .i2ptunnel.I2PTunnelClientBase: Unable to build tunnels for the client, retrying in 20 seconds
net.i2p.client.I2PSessionException: [GOTDATE shared clients #41198]: Failed to build tunnels
        at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:712)
        at net.i2p.i2ptunnel.I2PTunnelClientBase.connectManager(I2PTunnelClientBase.java:459)
        at net.i2p.i2ptunnel.I2PTunnelClientBase.verifySocketManager(I2PTunnelClientBase.java:240)
        at net.i2p.i2ptunnel.I2PTunnelClientBase.startRunning(I2PTunnelClientBase.java:525)
        at net.i2p.i2ptunnel.I2PTunnel.runClient(I2PTunnel.java:895)
        at net.i2p.i2ptunnel.TunnelController.startClient(TunnelController.java:478)
        at net.i2p.i2ptunnel.TunnelController.doStartTunnel(TunnelController.java:291)
        at net.i2p.i2ptunnel.TunnelController.startTunnel(TunnelController.java:242)
        at net.i2p.i2ptunnel.TunnelController$1.run(TunnelController.java:222)
        at java.lang.Thread.run(Thread.java:745)
        at net.i2p.util.I2PThread.run(I2PThread.java:103)
Caused by: java.io.IOException: No tunnels built after waiting 5 minutes. Your network connection may be down, or there is severe network congestion.
        at net.i2p.client.impl.I2PSessionImpl.connect(I2PSessionImpl.java:670)
        ... 10 more

System info

I2P version: 0.9.26-3
Java version: Oracle Corporation 1.8.0_92 (OpenJDK Runtime Environment 1.8.0_92-b14)
Wrapper version: 3.5.29
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
JSTL version: standard-taglib 1.2.0
Platform: Linux amd64 4.5.7-300.fc24.x86_64
Jcpuid version: 3
Processor: Haswell Core i3/i5/i7 model 69 (coreihwl)
Jbigi: Native BigInteger library libjbigi-linux-coreihwl_64.so loaded from resource
Jbigi version: 3
GMP version: 6.0.0
Encoding: UTF-8
Charset: UTF-8

Subtickets

#1812: Can't comment on ticket 1811closed

Change History (7)

comment:1 Changed 3 years ago by zzz

Component: unspecifiedrouter/general
Status: newinfoneeded_new

This looks like a network connectivity issue. You reseeded fine (Known: 111) but have essentially no connections to peers (Active: 1/1, and that probably isn't working either). Something is blocking outbound or inbound UDP and/or TCP. Firewall, iptables, antivirus, external routers, …

You could try reseeding again from /configreseed in the console ('save changes and reseed now' at the bottom) but that probably won't help.

comment:2 Changed 3 years ago by zzz

The Network: OK is obviously a false positive, things aren't OK at all.

comment:3 Changed 3 years ago by notrix

Add a subticket #1812.

comment:4 Changed 3 years ago by notrix

Status: infoneeded_newnew

I've verified that TCP is not blocked on the configured port, by running a http server on that port and using nmap from AWS. How to test if UDP is blocked?

comment:5 Changed 3 years ago by notrix

Dang, it's working now. Ran uninstaller.jar, removed all files (~/i2p and ~/.i2p) and reinstalled via i2pinstall_0.9.26.jar. Shouldn't have built from trunk I guess. Feel free to close the ticket.

comment:6 Changed 3 years ago by zzz

If trunk is broken, that's a problem, and we should leave the ticket open. But we've gotten no other reports of an issue with -3. So I'd like to get to the bottom of it.

comment:7 Changed 3 years ago by zzz

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.