Opened 3 years ago

Closed 2 years ago

#1814 closed defect (worksforme)

I2P-Bote not sending messages after upgrade from 0.3 to 0.4.3

Reported by: anonimal Owned by:
Priority: critical Milestone: undecided
Component: apps/plugins Version: 0.9.26
Keywords: I2P-Bote Cc:
Parent Tickets:

Description

From #i2p-dev:

+anonimal 24+ hours and Bote is still not delivering messages (sitting in Sent at 0% delivered).
+anonimal Network and kademlia peers are well-connected.
+anonimal I had upgraded from 0.3 to 0.4.3 by deleting plugin in /configclients, removing i2pbote directory entirely (just because), and then installed 0.4.3 from bote.i2p
+anonimal I can reproduce this on another machine using same process.

Restarting the router has no effect.

Subtickets

Change History (4)

comment:1 Changed 2 years ago by str4d

  • Status changed from new to infoneeded_new

I recently (a few days ago) sent a message to myself, so this isn't a global issue. Very likely related to the reliability of the I2P-Bote peers your node knows.

Could you enable debug logging for i2p.bote.service.OutboxProcessor and try again?

comment:2 Changed 2 years ago by anonimal

  • Status changed from infoneeded_new to new

i2p.bote.service.OutboxProcessor=true in http://127.0.0.1:7657/configadvanced isn't producing any debug output (not even after successfully sending a message). Do I need to tweak a log setting somewhere?

comment:3 Changed 2 years ago by anonimal

Good news: I've received a test message that I had sent to myself (within the past hour). I still haven't received the messages I sent back in July though.

Are they a lost cause? Should I close or rename this ticket?

comment:4 Changed 2 years ago by str4d

  • Resolution set to worksforme
  • Status changed from new to closed

For logging, you need i2p.bote.service.OutboxProcessor=DEBUG (or similar for other log levels). And yeah, the messages you sent in July will have been deleted by the network by now (since packets have a 100-day lifetime), so I'll close this ticket and you can make a new one if you encounter this again..

Note: See TracTickets for help on using tickets.