Opened 3 years ago

Closed 2 years ago

#1815 closed defect (fixed)

I2P-Bote not creating vanity destinations after upgrade from 0.3 to 0.4.3

Reported by: anonimal Owned by: str4d
Priority: minor Milestone: 0.9.28
Component: apps/plugins Version: 0.9.26
Keywords: I2P-Bote Cc:
Parent Tickets:

Description

  • Click Identities->New Identity
  • Enter Public name, keep default 256bit ECC
  • Type in a single letter (also tried with multiple letters), click Create
  • Responds with generation page, returns back to New Identity page
  • No new identity was created.

Note: creating a default generated destination works as expected.

Subtickets

Change History (2)

comment:1 Changed 2 years ago by str4d

  • Owner set to str4d
  • Status changed from new to accepted

I recreated the behaviour with the vanity character a. This bug was caused by the addition of XSS filtering; the error message for unsupported leading characters was being stripped. Using valid leading characters, vanity destinations worked fine for me.

comment:2 Changed 2 years ago by str4d

  • Milestone changed from undecided to 0.9.28
  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in 24a4f0352a275ad640b46d526c1cd521b069d1dc.

Note: See TracTickets for help on using tickets.