Opened 3 years ago

Closed 3 years ago

#1820 closed defect (fixed)

I2Phex v3.2.8.0.0-b1 (plugin) only show its splash screen but nothing more

Reported by: hummingbird Owned by: zzz
Priority: minor Milestone: 0.9.27
Component: apps/other Version: 0.9.26
Keywords: Cc:
Parent Tickets:

Description

  1. When trying to run the brand new I2Phex v3.2.8.0.0-b1 (plugin), I get the same old issues: 'the splash screen is visible for a brief moment before disappearing' ( http://i2pwiki.i2p/index.php?title=I2Phex#GUI ). But I am sure that I am logged in my GUI with the same username as the I2P router.
  1. So I decide to copy/paste the I2Phex files from the plugin folder to somewhere else and tried to run it manually as a standalone app, I get the following error log :
sh run.sh
160730 21:25:03,0282(0.0) Error/phex.servent.Servent:: java.lang.NoClassDefFoundError: net/i2p/data/DataFormatException
160730 21:25:03,0288(0.0) Error/phex.Main:: java.lang.NoClassDefFoundError: net/i2p/data/DataFormatException - Exception: java.lang.NoClassDefFoundError: net/i2p/data/DataFormatException
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:264)
	at phex.net.repres.PresentationManager.createInstance(PresentationManager.java:66)
	at phex.net.repres.PresentationManager.getInstance(PresentationManager.java:55)
	at phex.net.I2PServer.bind(I2PServer.java:208)
	at phex.net.Server.startup(Server.java:115)
	at phex.servent.Servent.doStart(Servent.java:204)
	at phex.common.AbstractLifeCycle.start(AbstractLifeCycle.java:56)
	at phex.Main.main(Main.java:165)
Caused by: java.lang.ClassNotFoundException: net.i2p.data.DataFormatException
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 9 more

Subtickets

Change History (1)

comment:1 Changed 3 years ago by zzz

  • Milestone changed from undecided to 0.9.27
  • Resolution set to fixed
  • Status changed from new to closed

Problem was in clients.config (-cp is ignored if -jar is specified)

Seems like this has been a problem for a long time?

fixed in f479e25ebdbefae554c6139b524c9f4e7d8da0a3 3.2.8.0.1-b1

Note: See TracTickets for help on using tickets.