Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1823 closed defect (fixed)

i2psnark errors - java.lang.StringIndexOutOfBoundsException: String index out of range: -1

Reported by: xmz Owned by: zzz
Priority: minor Milestone: 0.9.27
Component: apps/i2psnark Version: 0.9.26
Keywords: i2psnark, trackerclient Cc:
Parent Tickets:

Description

Hi,

I just started up i2psnark standalone, running with i2pd through I2CP.
I am seeing these errors in the console output:

Thread terminated unexpectedly: TrackerClient %02%1c%9aoqT #1 
java.lang.StringIndexOutOfBoundsException: String index out of range: -1 
        at java.lang.String.substring(String.java:1967) 
        at org.klomp.snark.TrackerClient$TCTracker.<init>(TrackerClient.java:948)
        at org.klomp.snark.TrackerClient.setup(TrackerClient.java:290)
        at org.klomp.snark.TrackerClient.run(TrackerClient.java:241)
        at java.lang.Thread.run(Thread.java:745)
        at net.i2p.util.I2PThread.run(I2PThread.java:103)
Thread terminated unexpectedly: TrackerClient %83%a9%93%cc #1
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
        at java.lang.String.substring(String.java:1967)
        at org.klomp.snark.TrackerClient$TCTracker.<init>(TrackerClient.java:948)
        at org.klomp.snark.TrackerClient.setup(TrackerClient.java:290)
        at org.klomp.snark.TrackerClient.run(TrackerClient.java:241)
        at java.lang.Thread.run(Thread.java:745)
        at net.i2p.util.I2PThread.run(I2PThread.java:103)

Upon checking the Java I2P router logs, I see the same messages.

Subtickets

Change History (3)

comment:1 Changed 3 years ago by zzz

  • Milestone changed from undecided to 0.9.27
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 78b4598b4c2281566f48e24e5f93a3460fcaf51f 0.9.26-8

Caused by not verifying that announce URL contained a path, i.e. not the invalid http://example.i2p - these will now be rejected.

This could have come in a torrent file (although your log shows it happened on two different torrents) or a bad announce URL configured manually. Some sort of i2pd-only or i2cp-only corruption seems less likely.

comment:2 Changed 3 years ago by xmz

I'm running many torrents which do not use a tracker, they are running solely on DHT.

On a different router with similar torrents, there are a large number of these errors too and with unique strings at the end of the "Thread terminated unexpectedly: TrackerClient?" line.

Thanks for the fix.

comment:3 Changed 3 years ago by xmz

Fix tested and confirmed to be good.

Note: See TracTickets for help on using tickets.