Opened 3 years ago

Closed 3 years ago

#1827 closed enhancement (fixed)

Add help for Debian users on the trac wiki Crypto/ECDSA page due to recent breakage of ECDSA support

Reported by: soapy Owned by: killyourtv
Priority: minor Milestone: 0.9.28
Component: www/i2p Version: 0.9.26
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

Debian recently pushed an update for OpenJDK7, at least for Wheezy and perhaps other versions, that breaks I2P's ECDSA support by default, resulting in an unsightly error for users, who are directed to http://trac.i2p2.i2p/wiki/Crypto/ECDSA

I have created a diff for the plain text version of that wiki page that adds a quick and easy solution for these users, and I believe that it would be helpful to apply it.

Thank you!

Diff follows:

24a25
> - Debian (confirmed in Wheezy, changelog marked 30 Jul 2016, applicability to other versions uncertain): since a recent OpenJDK7 update, the necessary .jar is no longer active by default - ensure the package `libbcprov-java` is installed, and then copy or link `bcprov.jar` from `/usr/share/java/` to `$JAVA_HOME/lib/ext/` - on Wheezy-amd64 using OpenJDK7, the full destination path is `/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/ext/`
29c30
< - Old or unusual OS without ECDSA support. See Red Hat above.
---
> - Old or unusual OS without ECDSA support. See Red Hat or Debian above.

Subtickets

Change History (1)

comment:1 Changed 3 years ago by zzz

Component: tracwww/i2p
Milestone: undecided0.9.28
Resolution: fixed
Status: newclosed

changes applied

Note: See TracTickets for help on using tickets.