Opened 3 years ago

Closed 3 years ago

#1828 closed defect (fixed)

Syndie v1.106b-3 + a older SWT : slowness when browsing between messages (and errors in the terminal log)

Reported by: hummingbird Owned by: zzz
Priority: major Milestone: n/a
Component: apps/syndie Version: 0.9.26
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

A way to reproduce the issue : open the forum 'Syndie chat', open the first message of a thread containing several messages ('Syndie minor release Spring 2016') then click the button 'Next' (message) several times.

Test with Syndie v1.106b-3 + the SWT.JAR file from the web (SWT 3.8.2/4.2.2, 6 February 2013. File name: swt-4.2.2-gtk-linux-x86_64.zip) (http://archive.eclipse.org/eclipse/downloads/drops4/R-4.2.2-201302041200/index.php#SWT) :

(Syndie:9975): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

(Syndie:9975): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

(Syndie:9975): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

(Syndie:9975): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

(Syndie:9975): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

...

Test with Syndie v1.106b-3 + the SWT.JAR file (2013, version.txt contain 'version 3.836') from Syndie 1.105b :

(Syndie:1258): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f6775e6ae00 (0x7f679452ae10)

(Syndie:1258): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f6775e6ae00 (0x7f679452aea0)

(Syndie:1258): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f6775e6ae00 (0x7f6794526570)

(Syndie:1258): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7f6775e6ae00 (0x7f6794482c30)

...

Test with Syndie v1.105b-0 (the errors are also in the terminal log, but there is no slowness between the messages) :

(Syndie:6975): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7ffa094b2e00 (0x7ffa29376a00)

(Syndie:6975): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7ffa094b2e00 (0x7ffa29376a00)

(Syndie:6975): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gclosure.c:688: unable to remove uninstalled invalidation notifier: 0x7ffa094b2e00 (0x7ffa29376a00)

...

Test with Syndie v1.106b-3 + the SWT.JAR file provided with (version 4.527, 2015) :

I can not really test it because it crash as soon as I open a forum. However here are the log until that :

(Syndie:8937): GLib-CRITICAL **: Source ID 466 was not found when attempting to remove it

(Syndie:8937): GLib-CRITICAL **: Source ID 1395 was not found when attempting to remove it

(Syndie:8937): GLib-CRITICAL **: Source ID 1528 was not found when attempting to remove it

(Syndie:8937): GLib-CRITICAL **: Source ID 1583 was not found when attempting to remove it

(Syndie:8937): Gdk-ERROR **: The program 'Syndie' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 15920 error_code 8 request_code 62 (core protocol) minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap

Subtickets

Change History (1)

comment:1 Changed 3 years ago by zzz

Milestone: undecidedn/a
Resolution: fixed
Status: newclosed

Build 1.106b-4 dev build which reverts to SWT 3.8.2.

See also #1297

I've had other problems with 4.x:

  • no splash screen on Ubuntu
  • Hangs on Lubuntu
Note: See TracTickets for help on using tickets.