Opened 3 years ago

Closed 3 years ago

#1830 closed defect (fixed)

NullPointerException when checking UPnP status

Reported by: Eugene321 Owned by:
Priority: minor Milestone: 0.9.27
Component: router/transport Version: 0.9.26
Keywords: upnp status Cc:
Parent Tickets:

Description

URL: http://127.0.0.1:7657/peers

Error details:

 Error 500: /peers Server Error

java.lang.NullPointerException
     at net.i2p.router.transport.UPnP.getDownstreamMaxBitRate(UPnP.java:468)
     at net.i2p.router.transport.UPnP.renderStatusHTML(UPnP.java:700)
     at net.i2p.router.transport.UPnPManager.renderStatusHTML(UPnPManager.java:296)
     at net.i2p.router.transport.TransportManager.renderStatusHTML(TransportManager.java:722)
     at net.i2p.router.transport.CommSystemFacadeImpl.renderStatusHTML(CommSystemFacadeImpl.java:215)
     at net.i2p.router.web.PeerHelper.getPeerSummary(PeerHelper.java:27)
     at net.i2p.router.web.jsp.peers_jsp._jspService(peers_jsp.java:335)
     at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
     at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:684)
     at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1496)
     at net.i2p.servlet.filters.XSSFilter.doFilter(XSSFilter.java:28)
     at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1476)
     at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:501)
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:137)
     at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:557)
     at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:231)
     at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1086)
     at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:429)
     at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:193)
     at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1020)
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:135)
     at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
     at net.i2p.router.web.LocaleWebAppHandler.handle(LocaleWebAppHandler.java:100)
     at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:255)
     at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:154)
     at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:116)
     at org.eclipse.jetty.server.Server.handle(Server.java:370)
     at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(AbstractHttpConnection.java:494)
     at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(AbstractHttpConnection.java:971)
     at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(AbstractHttpConnection.java:1033)
     at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:644)
     at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)
     at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)
     at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:696)
     at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:53)
     at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)
     at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)
     at java.lang.Thread.run(Unknown Source) 

I2P Version and Running Environment

I2P version: 0.9.26-0
Java version: Oracle Corporation 1.8.0_101 (Java(TM) SE Runtime Environment 1.8.0_101-b13)
Wrapper version: none
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: (corei)
Jbigi: Locally optimized native BigInteger library loaded from file

Maybe a dupe of #1779, however that was for version 0.9.24.

Subtickets

Change History (1)

comment:1 Changed 3 years ago by zzz

  • Component changed from router/general to router/transport
  • Milestone changed from undecided to 0.9.27
  • Resolution set to fixed
  • Status changed from new to closed

A rare UPnP device that doesn't support bit rate reporting.
Fixed in ce31abe17c3286542f25713428711d66b2223a5f 0.9.26-9
thank you

Note: See TracTickets for help on using tickets.