Opened 3 years ago

Closed 3 years ago

#1852 closed defect (duplicate)

Same "Error 500 server error"

Reported by: kittenpijama Owned by:
Priority: minor Milestone: 0.9.27
Component: apps/plugins Version: 0.9.26
Keywords: bote Cc:
Parent Tickets: #1793

Description

Hello, I have the same error on Debian Jessie (stable). I cannot press on any of the contacts buttons on email composing, and neither on "send" without going to the 500 error page.

My settings are:


I2P version: 0.9.26-0-1~deb8u+1
Java version: Oracle Corporation 1.7.0_111 (OpenJDK Runtime Environment 1.7.0_111-b01)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
JSTL version: standard-taglib 1.2.0
Platform: Linux i386 3.16.0-4-686-pae
Jcpuid version: 3
Processor: Haswell Core i3/i5/i7 model 60 (coreihwl)
Jbigi: Locally optimized native BigInteger? library loaded from file
Jbigi version: 3
GMP version: 5.1.3
Encoding: UTF-8
Charset: UTF-8


On Router Logs I can find:


9/27/16 1:10:28 PM ↓↓↓ 1 similar message omitted ↓↓↓
9/27/16 1:10:03 PM ↓↓↓ 1 similar message omitted ↓↓↓
9/27/16 1:09:46 PM ↓↓↓ 1 similar message omitted ↓↓↓
9/27/16 1:09:14 PM ↓↓↓ 3 similar messages omitted ↓↓↓
9/27/16 1:08:31 PM ↓↓↓ 1 similar message omitted ↓↓↓
9/27/16 1:08:09 PM WARN [ole Jetty-95] rg.eclipse.jetty.server.Server: Error for /i2pbote/newEmail.jsp: java.lang.NoClassDefFoundError?: com/sun/mail/util/LineInputStream
9/27/16 1:07:35 PM ↓↓↓ 7 similar messages omitted ↓↓↓
9/27/16 1:07:33 PM WARN [uter Console] rg.eclipse.jetty.server.Server: Couldn't initialize the InstanceManager? required by Tomcat Jasper: java.lang.ClassNotFoundException?: org.apache.tomcat.SimpleInstanceManager?
9/27/16 1:07:32 PM WARN [impleAppMain] .tunnel.BloomFilterIVValidator: Configured for 1.95MBps share bandwidth but only 113.75MB available memory. Recommend increasing wrapper.java.maxmemory in /usr/share/i2p/wrapper.config to at least 140 (MB) if the actual share bandwidth exceeds 512.00KBps.


And finally, the details of the error 500 page


HTTP ERROR 500

Problem accessing /i2pbote/newEmail.jsp. Reason:

Server Error

Caused by:

java.lang.NoClassDefFoundError?: com/sun/mail/util/LineInputStream

at javax.mail.internet.MimeMultipart?.parsebm(MimeMultipart?.java:747)
at javax.mail.internet.MimeMultipart?.parse(MimeMultipart?.java:466)
at javax.mail.internet.MimeMultipart?.getCount(MimeMultipart?.java:242)
at i2p.bote.web.MultipartFilter?.processRequest(MultipartFilter?.java:154)
at i2p.bote.web.MultipartFilter?.doFilter(MultipartFilter?.java:79)
at org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(ServletHandler?.java:1484)
at i2p.bote.web.CharsetFilter?.doFilter(CharsetFilter?.java:38)
at org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(ServletHandler?.java:1484)
at net.i2p.servlet.filters.XSSFilter.doFilter(XSSFilter.java:28)
at org.eclipse.jetty.servlet.ServletHandler?$CachedChain?.doFilter(ServletHandler?.java:1476)
at org.eclipse.jetty.servlet.ServletHandler?.doHandle(ServletHandler?.java:501)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:137)
at org.eclipse.jetty.security.SecurityHandler?.handle(SecurityHandler?.java:557)
at org.eclipse.jetty.server.session.SessionHandler?.doHandle(SessionHandler?.java:231)
at org.eclipse.jetty.server.handler.ContextHandler?.doHandle(ContextHandler?.java:1088)
at org.eclipse.jetty.servlet.ServletHandler?.doScope(ServletHandler?.java:429)
at org.eclipse.jetty.server.session.SessionHandler?.doScope(SessionHandler?.java:193)
at org.eclipse.jetty.server.handler.ContextHandler?.doScope(ContextHandler?.java:1022)
at org.eclipse.jetty.server.handler.ScopedHandler?.handle(ScopedHandler?.java:135)
at org.eclipse.jetty.server.handler.ContextHandlerCollection?.handle(ContextHandlerCollection?.java:255)
at org.eclipse.jetty.server.handler.HandlerCollection?.handle(HandlerCollection?.java:154)
at org.eclipse.jetty.server.handler.HandlerWrapper?.handle(HandlerWrapper?.java:116)
at org.eclipse.jetty.server.Server.handle(Server.java:370)
at org.eclipse.jetty.server.AbstractHttpConnection?.handleRequest(AbstractHttpConnection?.java:494)
at org.eclipse.jetty.server.AbstractHttpConnection?.content(AbstractHttpConnection?.java:982)
at org.eclipse.jetty.server.AbstractHttpConnection?$RequestHandler?.content(AbstractHttpConnection?.java:1043)
at org.eclipse.jetty.http.HttpParser?.parseNext(HttpParser?.java:865)
at org.eclipse.jetty.http.HttpParser?.parseAvailable(HttpParser?.java:240)
at org.eclipse.jetty.server.AsyncHttpConnection?.handle(AsyncHttpConnection?.java:82)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?.handle(SelectChannelEndPoint?.java:696)
at org.eclipse.jetty.io.nio.SelectChannelEndPoint?$1.run(SelectChannelEndPoint?.java:53)
at org.eclipse.jetty.util.thread.QueuedThreadPool?.runJob(QueuedThreadPool?.java:608)
at org.eclipse.jetty.util.thread.QueuedThreadPool?$3.run(QueuedThreadPool?.java:543)
at java.lang.Thread.run(Thread.java:745)

Powered by Jetty://


Subtickets

Change History (2)

comment:1 Changed 3 years ago by hummingbird

  • Component changed from unspecified to apps/plugins
  • Keywords bote added

comment:2 Changed 3 years ago by zzz

  • Milestone changed from undecided to 0.9.27
  • Resolution set to duplicate
  • Status changed from new to closed

See #1793 for resolution

Note: See TracTickets for help on using tickets.