Opened 3 years ago

Closed 3 years ago

#1881 closed defect (not a bug)

The hosts database was not closed cleanly or is still open by another process

Reported by: anonymous maybe Owned by:
Priority: minor Milestone:
Component: apps/addressbook Version: 0.9.27
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

i got this message in purple color inside "router logs" and i dont know if its bug or not but i will report it:-

I2P version: 0.9.27-0

Java version: Oracle Corporation 1.7.0_45 (Java™ SE Runtime Environment 1.7.0_45-b18)
Wrapper version: none
Server version: 8.1.17.v20150415
Servlet version: Jasper JSP 2.1 Engine
JSTL version: standard-taglib 1.2.0
Platform: Windows XP x86 5.1
Jcpuid version: 3
Processor: Ivy Bridge (coreisbr)
Jbigi: Locally optimized library jbigi-windows-coreisbr.dll loaded from file
Jbigi version: 3
GMP version: 6.0.0
Encoding: Cp1252
Charset: windows-1252

Note that system information, log timestamps, and log messages may provide clues to your location; please review everything you include in a bug report.

Router Logs
File location: C:\Documents and Settings\ehrecep\Application Data\I2P\logs\log-router-1.txt

15/11/16 16:05:20 WARN [Addressbook ] .naming.BlockfileNamingService?: The hosts database was not closed cleanly or is still open by another process

Service (Wrapper) Logs
File location: C:\Documents and Settings\ehrecep\My Documents\wrapper.log

2016/11/13 18:16:38 | Unable to write to the configured log directory: C:\Documents and Settings\ehrecep\Application Data\i2p (The system cannot find the path specified. (0x3))
2016/11/13 18:16:38 | The directory does not exist.
2016/11/13 18:16:38 | Unable to write to the configured log file: C:\Documents and Settings\ehrecep\Application Data\i2p\wrapper.log (The system cannot find the path specified. (0x3))
2016/11/13 18:16:38 | Falling back to the default file in the current working directory: wrapper.log
2016/11/13 18:16:39 | Unable to write to the configured log directory: C:\Documents and Settings\ehrecep\Application Data\i2p (The system cannot find the path specified. (0x3))
2016/11/13 18:16:39 | The directory does not exist.
2016/11/13 18:16:39 | Unable to write to the configured log file: C:\Documents and Settings\ehrecep\Application Data\i2p\wrapper.log (The system cannot find the path specified. (0x3))
2016/11/13 18:16:39 | Falling back to the default file in the current working directory: wrapper.log
2016/11/13 18:16:39 | Unable to install the I2P Service service - Access is denied. (0x5)
Setting up new user directory C:\Documents and Settings\ehrecep\Application Data\I2P
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\cgi-bin
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\contexts
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\contexts\base-context.xml
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\contexts\cgi-context.xml
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\docroot
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\favicon.ico
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\docroot\help
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_de.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_es.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_fr.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_na.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_nl.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_ru.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_sv.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\index_zh.html
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\docroot\help\lib
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\bg.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\brown.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\cn.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\de.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\eepsite.css
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\es.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\fr.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\h2bg.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\ir.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\it.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\itoopie.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\jp.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\nl.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\ru.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\se.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\lib\us.png
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\help\pagetemplate.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\index.html
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\docroot\robots.txt
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\etc
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\etc\realm.properties
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\etc\webdefault.xml
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\jetty-jmx.xml
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\jetty-rewrite.xml
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\jetty-ssl.xml
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\jetty.xml
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\logs
Created C:\Documents and Settings\ehrecep\Application Data\I2P\eepsite\webapps
Copied C:\Documents and Settings\ehrecep\My Documents\hosts.txt
Copied C:\Documents and Settings\ehrecep\My Documents\i2psnark.config
Copied C:\Documents and Settings\ehrecep\My Documents\i2ptunnel.config
Copied C:\Documents and Settings\ehrecep\My Documents\systray.config
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\jetty.xml with modifications
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\jetty-ssl.xml with modifications
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\contexts\base-context.xml with modifications
Copied C:\Documents and Settings\ehrecep\My Documents\eepsite\contexts\cgi-context.xml with modifications
Copied C:\Documents and Settings\ehrecep\My Documents\clients.config with modifications
Successfully copied data files to new user directory C:\Documents and Settings\ehrecep\Application Data\I2P
INFO: Native CPUID library jcpuid-x86-windows.dll loaded from resource
trying to load resource: jbigi-windows-coreisbr.dll
Loaded library: jar:file:/C:/Documents%20and%20Settings/ehrecep/My%20Documents/lib/jbigi.jar!/jbigi-windows-coreisbr.dll
INFO: Native BigInteger? library jbigi-windows-coreisbr.dll loaded from resource
Reseed start
Reseeding from https://i2p.manas.ca:8443/i2pseeds.su3
Unable to bind routerconsole to ::1 port 7657: java.io.IOException: IPv6 addresses unsupported
You may ignore this warning if the console is still available at http://localhost:7657
Reseed got no router infos from https://i2p.manas.ca:8443/i2pseeds.su3
Reseeding from https://i2p-0.manas.ca:8443/i2pseeds.su3
INFO: Addressbook directory addressbook created
Reseed got no router infos from https://i2p-0.manas.ca:8443/i2pseeds.su3
Reseeding from https://reseed.i2p.vzaws.com:8443/i2pseeds.su3
INFO: 75 files extracted to C:\DOCUME~1\ehrecep\LOCALS~1\Temp\i2p-7rYEy9BQ.tmp\reseeds-32809127
Reseed got 75 router infos from https://reseed.i2p.vzaws.com:8443/i2pseeds.su3 with 0 errors
Reseeding from https://i2p.mooo.com/netDb/i2pseeds.su3
INFO: 86 files extracted to C:\DOCUME~1\ehrecep\LOCALS~1\Temp\i2p-7rYEy9BQ.tmp\reseeds-573298158
Reseed got 86 router infos from https://i2p.mooo.com/netDb/i2pseeds.su3 with 0 errors
Reseed complete, 161 received
13/11/16 19:30:37 CRIT [ShutdownHook?] net.i2p.router.Router : Graceful shutdown progress: No more tunnels, starting final shutdown
13/11/16 19:30:39 CRIT [ShutdownHook?] net.i2p.router.Router : Starting final shutdown(2)
13/11/16 19:30:41 CRIT [ShutdownHook?] net.i2p.router.Router : Shutdown(2) complete
WARN: There may be another router already running. Waiting a while to be sure…
WARN: Old router was not shut down gracefully, deleting C:\Documents and Settings\ehrecep\Application Data\I2P\router.ping
INFO: Native CPUID library jcpuid-x86-windows loaded from file
INFO: Locally optimized library jbigi-windows-coreisbr.dll loaded from file
Unable to bind routerconsole to ::1 port 7657: java.io.IOException: IPv6 addresses unsupported
You may ignore this warning if the console is still available at http://localhost:7657
ERROR: There appears to be another router already running!

Please make sure to shut down old instances before starting up
a new one. If you are positive that no other instance is running,
please delete the file C:\Documents and Settings\ehrecep\Application Data\I2P\router.ping

WARN: There may be another router already running. Waiting a while to be sure…
WARN: Old router was not shut down gracefully, deleting C:\Documents and Settings\ehrecep\Application Data\I2P\router.ping
INFO: No, there wasn't another router already running. Proceeding with startup.
INFO: Native CPUID library jcpuid-x86-windows loaded from file
INFO: Locally optimized library jbigi-windows-coreisbr.dll loaded from file
WARN: Old router was not shut down gracefully, deleting C:\Documents and Settings\ehrecep\Application Data\I2P\router.ping
INFO: Native CPUID library jcpuid-x86-windows loaded from file
INFO: Locally optimized library jbigi-windows-coreisbr.dll loaded from file
Unable to bind routerconsole to ::1 port 7657: java.io.IOException: IPv6 addresses unsupported
You may ignore this warning if the console is still available at http://localhost:7657
14/11/16 17:04:41 CRIT 1/1? uter.startup.LoadRouterInfoJob?: Error reading the router info from C:\Documents and Settings\ehrecep\Application Data\I2P\router.info and the keys from C:\Documents and Settings\ehrecep\Application Data\I2P\router.keys
java.io.EOFException: EOF reading 8 byte value

at net.i2p.data.DataHelper?.readLong(DataHelper?.java:656)
at net.i2p.data.router.RouterInfo?.readBytes(RouterInfo?.java:570)
at net.i2p.data.router.RouterInfo?.readBytes(RouterInfo?.java:528)
at net.i2p.router.startup.LoadRouterInfoJob?.loadRouterInfo(LoadRouterInfoJob?.java:96)
at net.i2p.router.startup.LoadRouterInfoJob?.runJob(LoadRouterInfoJob?.java:56)
at net.i2p.router.JobQueueRunner?.runCurrentJob(JobQueueRunner?.java:135)
at net.i2p.router.JobQueueRunner?.run(JobQueueRunner?.java:78)

WARN: Old router was not shut down gracefully, deleting C:\Documents and Settings\ehrecep\Application Data\I2P\router.ping
INFO: Native CPUID library jcpuid-x86-windows loaded from file
INFO: Locally optimized library jbigi-windows-coreisbr.dll loaded from file
Unable to bind routerconsole to ::1 port 7657: java.io.IOException: IPv6 addresses unsupported
You may ignore this warning if the console is still available at http://localhost:7657

Subtickets

Change History (1)

comment:1 Changed 3 years ago by zzz

Component: unspecifiedapps/addressbook
Milestone: undecided
Resolution: not a bug
Status: newclosed

Either your previous router instance crashed, or you have another instance (possibly as a service?) running on the same maching. If everything is working fine, you may ignore the warning.

Note: See TracTickets for help on using tickets.