Opened 2 years ago

Closed 2 years ago

#1895 closed defect (fixed)

Orchid Does Not Deliver HTTPS Sites

Reported by: atran Owned by: zzz
Priority: minor Milestone: 0.9.29
Component: apps/i2ptunnel Version: 0.9.28
Keywords: Cc:
Parent Tickets:

Description

I'll begin by noting that this is a duplicate of #1364, and I was advised at
http://forum.i2p/viewtopic.php?t=11537 to reopen that ticket with further information, but I was unable to do so, and in fact find myself unable to comment on any existing ticket. Perhaps my account is too new? I digress.

The Problem

I am unable to load HTTPS sites through the orchid plugin.

Steps to Reproduce

  1. Install zzz's version of the Orchid plugin from http://stats.i2p/i2p/plugins/orchid.su3 using the router's /configplugins page.
  2. Visit /i2ptunnelmgr, click on I2P HTTP Proxy, tick the "Use Outproxy Plugin" box, click Save.
  3. Repeat (2) on the I2P HTTPS Proxy link.

Expected Results

http and https sites should be served via the Orchid plugin, i.e. via Tor.

Actual Results

Under the I2P HTTP Proxy heading, we see "Outproxy: Internal plugin". But under the I2P HTTPS Proxy heading, we see "Outproxy: outproxy.tor-meeh.i2p", the default outproxy. Furthermore, one notes by checking /orchid that http sites are delivered via the orchid plugin (by noting the circuits built), but https sites are not. I can provide further details to justify this claim, as necessary.

Further Information

The logs show nothing out of the ordinary.

Version information:
I2P version: 0.9.28-0
Java version: Oracle Corporation 1.8.0_72 (OpenJDK Runtime Environment 1.8.0_72-b15)
Wrapper version: 3.5.20
Server version: 8.1.21.v20160908
Servlet version: Jasper JSP 2.1 Engine
JSTL version: standard-taglib 1.2.0
Platform: OpenBSD amd64 6.0
Jcpuid version: 0
Processor: uninitialized (unrecognized)
Jbigi: Native BigInteger? library jbigi not loaded - using pure Java - poor performance may result - see http://i2p-projekt.i2p/jbigi for help
Jbigi version: 0
GMP version: unknown
Encoding: UTF-8
Charset: UTF-8

Thanks very much!

Subtickets

Change History (5)

comment:1 Changed 2 years ago by atran

I've either fixed this non-issue or found a workaround, depending on whether this is considered a bug or not; I genuinely don't have enough knowledge to be certain.

The Fix

I had my HTTP proxy set to 127.0.0.1:4444, and my SSL proxy set to 127.0.0.1:4445. Redirecting SSL traffic to 127.0.0.1:4444 routes everything through Orchid, and it all works as expected. I'm still not entirely sure if the HTTPS Proxy is meant to route traffic through Orchid when the "Use Outproxy Plugin" box is ticked, but anyway this fixes it.

I apologize for the noise if this ends up wholly irrelevant. Perhaps my one comment would be that it took a bit of doing to find directions on how to configure the router after the plugin was installed, so maybe some documentation would be helpful for others? I'd be happy to write something up, if it is deemed useful.

comment:2 Changed 2 years ago by zzz

  • Owner set to zzz
  • Status changed from new to accepted

Wow, thank you. That was indeed the problem. The "connect" proxy on port 4445 does not support the outproxy plugin. Since the HTTP proxy on port 4444 supports HTTPS now, we haven't done much maintenance on the connect proxy. I'll think about whether to add plugin support to the connect proxy, or just close this wontfix. Thanks again for the help.

comment:3 Changed 2 years ago by zzz

OK, the CONNECT proxy config page does show a 'use outproxy plugin' setting (as you said in step 3 of the OP), so that's a bug if we aren't going to add support.

comment:4 Changed 2 years ago by zzz

  • Milestone changed from undecided to 0.9.29

Will add support for 0.9.29.

comment:5 Changed 2 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in 36e82a882c02917f7f60e5203d53201b4fccdd55 to be 0.9.28-5

Note: See TracTickets for help on using tickets.