Opened 2 years ago

Closed 2 years ago

#1903 closed defect (duplicate)

Way to reproduce issues described in 1893

Reported by: jogger Owned by: zzz
Priority: major Milestone: 0.9.29
Component: apps/i2psnark Version: 0.9.28
Keywords: Cc:
Parent Tickets: #1893

Description

mkdir test; cd test
echo something > something
echo something > \*

Create torrent test.
Shutdown router.
Simulate data corruption by rm everthing in ~/.i2p/i2psnark.config.d except the config file.
Although torrent is still perfect, rescan of the torrent fails and following bugs appear:

  • file something is marked as incomplete
  • file "*" is recreated as "_" (works the same with "?" and '"')
  • if test does not reside in the snark data dir, all files and directories are recreated in the data dir.

This type of corruption has been observed many times on restart with no participating tunnels or on sudden crashes. Files did reside on ext4 or btrfs, config dir was on ext4. Newer torrents (some days) usually seem to be affected.

Workaround: recreating the torrent from originals works, because the info hash is the same.

Subtickets

Change History (1)

comment:1 Changed 2 years ago by zzz

  • Milestone changed from undecided to 0.9.29
  • Resolution set to duplicate
  • Status changed from new to closed

see #1893 for resolution

Note: See TracTickets for help on using tickets.