Opened 2 years ago

Closed 2 years ago

#1927 closed defect (not a bug)

ter.networkdb.reseed.Reseeder: EepGet failed on https://download.xxlspeed.com/i2pseeds.su3

Reported by: anonymous maybe Owned by:
Priority: minor Milestone: n/a
Component: www/reseed Version: 0.9.28
Keywords: Cc:
Parent Tickets:

Description (last modified by zzz)

there r couple of errors in router logs check

  • I2P Version and Running Environment
I2P version: 0.9.28-0-1ubuntu1
Java version: Oracle Corporation 1.7.0_111 (OpenJDK Runtime Environment 1.7.0_111-b01)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
JSTL version: standard-taglib 1.2.0
Platform: Linux amd64 3.16.0-4-amd64
Jcpuid version: 3
Processor: Westmere (corei)
Jbigi: Locally optimized native BigInteger library loaded from file
Jbigi version: 4
GMP version: 6.0.0
Encoding: UTF-8
Charset: UTF-8


  • Critical Logs
    1/13/17 5:02:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 4:27:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 4:00:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 3:05:42 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 1:50:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 11:42:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 10:49:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 10:37:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 9:47:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 4:25:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 3:01:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 1:07:41 AM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 11:48:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 11:00:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 10:10:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 9:08:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 8:10:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 6:41:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 3:15:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/12/17 1:31:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!

  • Router Logs
    1/13/17 5:56:39 PM ERROR [Queue Pumper] net.i2p.router.JobQueue : Job ReadJob: Job 18: DB Read Job out of order with job ExpireJob: Job 343818: Expire our tunnel difference of 714ms
    1/13/17 5:54:36 PM WARN [Reseed ] uter.networkdb.reseed.Reseeder: EepGet failed on https://download.xxlspeed.com/i2pseeds.su3 : javax.net.ssl.SSLHandshakeException: SSL hostname verify failed, Expected download.xxlspeed.com - set i2p.disableSSLHostnameVerification=true to disable verification (dangerous!)
    1/13/17 5:54:32 PM WARN [JobQueue 1/1] networkdb.reseed.ReseedChecker: Very few known peers remaining - reseeding now
    1/13/17 5:04:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Memory: 61.65MB / 227.50MB
    1/13/17 5:04:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Outbound send rate: 842Bps
    1/13/17 5:04:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: 1 minute send processing time: 289ms
    1/13/17 5:04:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Participating tunnel count: 0
    1/13/17 5:04:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Job lag: 0
    1/13/17 5:04:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Ready and waiting jobs: 0
    1/13/17 5:04:41 PM ERROR [uterWatchdog] client.ClientManagerFacadeImpl: Client Y1KNrD has a leaseSet that expired 12m ago
    1/13/17 5:03:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Memory: 59.38MB / 227.50MB
    1/13/17 5:03:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Outbound send rate: 842Bps
    1/13/17 5:03:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: 1 minute send processing time: 289ms
    1/13/17 5:03:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Participating tunnel count: 0
    1/13/17 5:03:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Job lag: 0
    1/13/17 5:03:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Ready and waiting jobs: 0
    1/13/17 5:03:41 PM ERROR [uterWatchdog] client.ClientManagerFacadeImpl: Client Y1KNrD has a leaseSet that expired 11m ago
    1/13/17 5:02:41 PM CRIT [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion. Watchdog starts barking!
    1/13/17 5:02:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Memory: 56.20MB / 227.50MB
    1/13/17 5:02:41 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Outbound send rate: 491Bps

  • Service (Wrapper) Logs
2017/01/14 05:24:56 | Reseed start
2017/01/14 05:24:56 | Reseeding from https://reseed.atomike.ninja/i2pseeds.su3
2017/01/14 05:24:57 | INFO: 77 files extracted to /tmp/i2p-MfhD1s~n.tmp/reseeds-452333292
2017/01/14 05:24:57 | Reseed got 77 router infos from https://reseed.atomike.ninja/i2pseeds.su3 with 0 errors
2017/01/14 05:24:57 | Reseeding from https://reseed.i2p-projekt.de/i2pseeds.su3
2017/01/14 05:25:01 | INFO: 88 files extracted to /tmp/i2p-MfhD1s~n.tmp/reseeds-403422350
2017/01/14 05:25:01 | Reseed got 88 router infos from https://reseed.i2p-projekt.de/i2pseeds.su3 with 0 errors
2017/01/14 05:25:01 | Reseed complete, 165 received
2017/01/14 05:28:34 | CRIT  [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion.  Watchdog starts barking!
2017/01/14 06:03:22 | CRIT  [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion.  Watchdog starts barking!
2017/01/14 06:55:01 | Reseed start
2017/01/14 06:55:01 | Reseeding from https://reseed.atomike.ninja/i2pseeds.su3
2017/01/14 06:55:03 | INFO: 77 files extracted to /tmp/i2p-MfhD1s~n.tmp/reseeds-821980494
2017/01/14 06:55:03 | Reseed got 77 router infos from https://reseed.atomike.ninja/i2pseeds.su3 with 0 errors
2017/01/14 06:55:03 | Reseeding from https://download.xxlspeed.com/i2pseeds.su3
2017/01/14 06:55:05 | Reseed got no router infos from https://download.xxlspeed.com/i2pseeds.su3
2017/01/14 06:55:05 | Reseeding from https://i2p-0.manas.ca:8443/i2pseeds.su3
2017/01/14 06:55:08 | INFO: 77 files extracted to /tmp/i2p-MfhD1s~n.tmp/reseeds-1064952647
2017/01/14 06:55:08 | Reseed got 77 router infos from https://i2p-0.manas.ca:8443/i2pseeds.su3 with 0 errors
2017/01/14 06:55:08 | Reseed complete, 154 received

Subtickets

Change History (2)

comment:1 Changed 2 years ago by anonymous maybe

after restarting the router this is what gaves me (more clear logs):-

  • Router Logs
1/13/17 7:36:24 PM WARN  [JobQueue 4/5] networkdb.reseed.ReseedChecker: Very few known peers remaining - reseeding now
1/13/17 7:36:24 PM INFO  [uter Console] rg.eclipse.jetty.server.Server: Please ignore any InstanceManager warnings
1/13/17 7:36:25 PM WARN  [uter Console] rg.eclipse.jetty.server.Server: Couldn't initialize the InstanceManager required by Tomcat Jasper: java.lang.ClassNotFoundException: org.apache.tomcat.SimpleInstanceManager
1/13/17 7:36:27 PM ^^^ 6 similar messages omitted ^^^
1/13/17 7:38:38 PM WARN  [Reseed      ] uter.networkdb.reseed.Reseeder: EepGet failed on https://us.reseed.i2p2.no:444/i2pseeds.su3 : java.net.ConnectException: Connection timed out (Connection timed out)
1/13/17 9:37:22 PM ERROR [uterWatchdog] client.ClientManagerFacadeImpl: Client hgioo3 has a leaseSet that expired 10m ago
1/13/17 9:37:22 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Ready and waiting jobs: 0
1/13/17 9:37:22 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Job lag: 0
1/13/17 9:37:22 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Participating tunnel count: 0
1/13/17 9:37:22 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: 1 minute send processing time: 145ms
1/13/17 9:37:22 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Outbound send rate: 651Bps
1/13/17 9:37:22 PM ERROR [uterWatchdog] 2p.router.tasks.RouterWatchdog: Memory: 44.30MB / 444.50MB
1/13/17 9:37:22 PM CRIT  [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion.  Watchdog starts barking!

  • Service (Wrapper) Logs
2017/01/14 08:36:45 | Launching a JVM...
2017/01/14 08:36:48 | WrapperManager: Initializing...
2017/01/14 08:36:48 | Starting I2P 0.9.28-0-1ubuntu1
2017/01/14 08:36:49 | INFO: Native CPUID library jcpuid-x86-linux loaded from file
2017/01/14 08:36:49 | INFO: Locally optimized native BigInteger library loaded from file
2017/01/14 08:36:52 | Reseed start
2017/01/14 08:36:52 | Reseeding from https://reseed.atomike.ninja/i2pseeds.su3
2017/01/14 08:36:58 | INFO: 77 files extracted to /tmp/i2p-7cdJdvJY.tmp/reseeds-522233755
2017/01/14 08:36:58 | Reseed got 77 router infos from https://reseed.atomike.ninja/i2pseeds.su3 with 0 errors
2017/01/14 08:36:58 | Reseeding from https://us.reseed.i2p2.no:444/i2pseeds.su3
2017/01/14 08:39:07 | Reseed got no router infos from https://us.reseed.i2p2.no:444/i2pseeds.su3
2017/01/14 08:39:07 | Reseeding from https://reseed.i2p.vzaws.com:8443/i2pseeds.su3
2017/01/14 08:39:09 | INFO: 75 files extracted to /tmp/i2p-7cdJdvJY.tmp/reseeds-612160967
2017/01/14 08:39:09 | Reseed got 75 router infos from https://reseed.i2p.vzaws.com:8443/i2pseeds.su3 with 0 errors
2017/01/14 08:39:09 | Reseed complete, 152 received
2017/01/14 10:38:08 | CRIT  [uterWatchdog] 2p.router.tasks.RouterWatchdog: Router appears hung, or there is severe network congestion.  Watchdog starts barking!

comment:2 Changed 2 years ago by zzz

  • Component changed from unspecified to www/reseed
  • Description modified (diff)
  • Milestone changed from undecided to n/a
  • Resolution set to not a bug
  • Status changed from new to closed

The relevant log line is:

1/13/17 5:54:36 PM WARN [Reseed ] uter.networkdb.reseed.Reseeder: EepGet? failed on https://download.xxlspeed.com/i2pseeds.su3 : javax.net.ssl.SSLHandshakeException: SSL hostname verify failed, Expected download.xxlspeed.com - set i2p.disableSSLHostnameVerification=true to disable verification (dangerous!)

Which is caused by Java 7 not fully supporting SNI. Update to Java 8 should fix this. This isn't an issue because not all reseeds require SNI, and the reseed process will keep going until it gets reseed data from somebody, as you can see in the logs above.

Note: See TracTickets for help on using tickets.