Opened 3 years ago

Closed 2 weeks ago

#1934 closed enhancement (not a bug)

unclutter peers page

Reported by: jogger Owned by: sadie
Priority: minor Milestone: 0.9.38
Component: apps/console Version: 0.9.28
Keywords: peers page Cc: sadie
Parent Tickets: #2330 Sensitive: no

Description

Proposal:

  • move upnp stuff to bottom of network settings page
  • move router stuff to local address tab
  • collapse peers lists into 8 expandable summary lines for all combinations of tcp/udp, ipv4/6, in-/outbound

reasons: Page can take > 1 minute to load. Network checks are tedious when scrolling through thousands of lines.

Subtickets

Change History (9)

comment:1 Changed 3 years ago by zzz

Cc: str4d added
Component: unspecifiedapps/console
Milestone: undecided0.9.30
Status: newopen

agreed it's a mess. My preference is to add tabs like for /netdb and /profiles pages. Will defer to .30 to await ui prop, to figure out something that aligns with that redesign and avoids merge issues. str4d may have opinions here also.

comment:2 Changed 20 months ago by zzz

Milestone: 0.9.300.9.34

@str4d please review and respond

comment:3 Changed 17 months ago by zzz

Milestone: 0.9.340.9.36

comment:4 Changed 16 months ago by zzz

Owner: set to zzz
Status: openaccepted

my problem now

comment:5 Changed 13 months ago by zzz

Cc: sadie added; str4d removed
Milestone: 0.9.360.9.38
Parent Tickets: 2330

Tabbed the /peers page in c13c107bbe8aa18b50520e9ec27cb90fa120d096 to be 0.9.37-2.

As stated in OP, and drz pointed out in IRC, the UPnP and addresses section may need to move somewhere else, or the page needs to be renamed as 'network status' or similar.

TBD, possibly dependent on other #2330 decisions.

comment:6 Changed 6 months ago by zzz

Owner: changed from zzz to sadie
Status: acceptedassigned

comment:7 Changed 5 weeks ago by sadie

Sensitive: unset

The /peers page seems to be not cluttered at this point.
link to page referenced "Network Configuration page" needs to be added on upnp page
Page could be renamed I2P Network Status and Peers or I2P Network Status Information

comment:8 Changed 5 weeks ago by zzz

we can rename it to whatever you want on the page itself, however there's also two "Peers" links in the sidebar and limited space there

comment:9 Changed 2 weeks ago by sadie

Resolution: not a bug
Status: assignedclosed

Closing ticket - this page has been uncluttered during past releases.

Note: See TracTickets for help on using tickets.