Opened 3 years ago

Closed 3 years ago

#1946 closed defect (not a bug)

Bote possible NPE

Reported by: zzz Owned by: str4d
Priority: minor Milestone: undecided
Component: apps/plugins Version: 0.9.28
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

At i2p.bote.network.Ping line 84, if session.receiveMessage() returns null, which is allowed per the javadocs, bote will NPE. The other place this is called, in I2PPacketDispatcher, does check for null.

Subtickets

Change History (2)

comment:1 Changed 3 years ago by zzz

The NPE is caught a couple lines below, however, so it won't crash anything.

comment:2 Changed 3 years ago by zzz

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.