Opened 3 years ago

Closed 3 years ago

#1969 closed defect (not a bug)

uter.startup.LoadClientAppsJob: Error starting up the client class net.i2p.router.web.RouterConsoleRunner

Reported by: Eche|on Owned by:
Priority: major Milestone: undecided
Component: apps/jetty Version: 0.9.29
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

CRIT [uter Console] uter.startup.LoadClientAppsJob?: Error starting up the client class net.i2p.router.web.RouterConsoleRunner?
2017/03/14 18:31:52 | java.lang.NoClassDefFoundError?: org/eclipse/jetty/server/HttpConfiguration$Customizer
2017/03/14 18:31:52 | at java.lang.Class.forName0(Native Method)
2017/03/14 18:31:52 | at java.lang.Class.forName(Class.java:348)
2017/03/14 18:31:52 | at net.i2p.router.startup.LoadClientAppsJob?$RunApp?.run(LoadClientAppsJob?.java:276)
2017/03/14 18:31:52 | at java.lang.Thread.run(Thread.java:745)
2017/03/14 18:31:52 | at net.i2p.util.I2PThread.run(I2PThread.java:103)
2017/03/14 18:31:52 | Caused by: java.lang.ClassNotFoundException?: org.eclipse.jetty.server.HttpConfiguration?$Customizer
2017/03/14 18:31:52 | at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
2017/03/14 18:31:52 | at java.lang.ClassLoader?.loadClass(ClassLoader?.java:424)
2017/03/14 18:31:52 | at sun.misc.Launcher$AppClassLoader?.loadClass(Launcher.java:331)
2017/03/14 18:31:52 | at java.lang.ClassLoader?.loadClass(ClassLoader?.java:357)
2017/03/14 18:31:52 | … 5 more

Subtickets

Change History (1)

comment:1 Changed 3 years ago by zzz

Resolution: not a bug
Status: newclosed

OP did not build with 'ant updaterWithJetty', still had Jetty 8 jars. Worked fine after updating the Jetty jars. http://zzz.i2p/topics/2256

Note: See TracTickets for help on using tickets.