Opened 2 years ago

Closed 18 months ago

#1987 closed defect (not our bug)

i2psnark system freeze/lockup on Linux raspberrypi 4.4.50-v7+

Reported by: yaof2017 Owned by: zzz
Priority: minor Milestone: undecided
Component: apps/i2psnark Version: 0.9.30
Keywords: freeze lock up restart Cc:
Parent Tickets:

Description

i2psnark system freeze/lockup

I'm running I2P on a Raspberry Pi 2 B (4-core, 1gig), Raspian Jessie. A kind of headless server setup.

uname -a = Linux raspberrypi 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 armv7l GNU/Linux

Base install. In the sense that I have changed nothing. No mods of any significance. Set the bandwidth to half. Just learning how to use it.

It seems to work OK. Will run for weeks. I can browse eepsites. Send SusiMail?. Create this ticket.

Except that, if I start i2psnark on a big (multi-gigabyte) torrent, the system completely
locks up after about 2 hours. Just gets slower and slower and locks up. At which point nothing works. Even ctrl/alt/f2 to get another terminal fails. I have to cycle the power to restart.

Nothing in any of the logs ~/.i2p or other, /var/log/syslog, suggest any kind of problem.

This is very consistent. EVERY TIME I start i2psnark, the Pi locks up about 2 hours later. Smaller torrents a little longer. There is nothing else running on the machine. But with absolute confidence, it will lock up.

I installed the command line packages for Transmission. Transmission will download big torrents, on the same machine, without a problem.

I put in a free -h command every 5 minutes, and the memory used and cached just goes up and up.

Because all of i2p works, except snark, and because bittorrent works outside of i2p, I get the feeling it's not something I have done.

I don't want to waste your time, but I have no ideas?

yaof2017

I2P version: 0.9.29-0-1ubuntu1
Java version: Oracle Corporation 1.8.0_65 (Java(TM) SE Runtime Environment 1.8.0_65-b17)
Wrapper version: 3.5.25
Server version: 8.1.16.v20140903
Servlet version: Jasper JSP 2.1 Engine
JSTL version: standard-taglib 1.2.0
Platform: Linux arm 4.4.50-v7+
Processor: (armcortexa7)
Jbigi: Locally optimized native BigInteger? library loaded from file
Jbigi version: 2
GMP version: unknown
Encoding: ANSI_X3.4-1968
Charset: US-ASCII

Critical Logs
No log messages

pi@raspberrypi:~/tmp $ cat Fri.txt
Fri May 5 09:51:39 ICT 2017

total used free shared buffers cached

Mem: 925M 307M 618M 6.3M 45M 138M
-/+ buffers/cache: 122M 802M
Swap: 2.1G 0B 99M
Fri May 5 09:56:41 ICT 2017

total used free shared buffers cached

Mem: 925M 331M 594M 6.3M 46M 140M
-/+ buffers/cache: 144M 781M
Swap: 2.1G 0B 2.1G
Fri May 5 10:01:42 ICT 2017

total used free shared buffers cached

Mem: 925M 332M 593M 6.3M 46M 142M
-/+ buffers/cache: 143M 781M
Swap: 2.1G 0B 2.1G
Fri May 5 10:06:45 ICT 2017

total used free shared buffers cached

Mem: 925M 347M 578M 6.3M 46M 147M
-/+ buffers/cache: 153M 772M
Swap: 2.1G 0B 2.1G
Fri May 5 10:11:48 ICT 2017

total used free shared buffers cached

Mem: 925M 369M 556M 6.3M 47M 159M
-/+ buffers/cache: 162M 763M
Swap: 2.1G 0B 2.1G

... more of the same deleted...

Fri May 5 11:48:00 ICT 2017

total used free shared buffers cached

Mem: 925M 561M 363M 6.3M 52M 326M
-/+ buffers/cache: 183M 742M
Swap: 2.1G 0B 2.1G
Fri May 5 11:53:22 ICT 2017

total used free shared buffers cached

Mem: 925M 565M 360M 6.3M 52M 328M
-/+ buffers/cache: 183M 741M
Swap: 2.1G 0B 2.1G
Fri May 5 11:58:45 ICT 2017

total used free shared buffers cached

Mem: 925M 570M 355M 6.3M 53M 329M
-/+ buffers/cache: 187M 737M
Swap: 2.1G 0B 2.1G
Fri May 5 12:04:07 ICT 2017

total used free shared buffers cached

Mem: 925M 559M 365M 6.3M 53M 320M
-/+ buffers/cache: 185M 740M
Swap: 2.1G 0B 2.1G
Fri May 5 12:09:37 ICT 2017

total used free shared buffers cached

Mem: 925M 560M 365M 6.3M 53M 328M
-/+ buffers/cache: 177M 747M
Swap: 2.1G 0B 2.1G
pi@raspberrypi:~/tmp $

pi@raspberrypi:~ $

top - 14:12:30 up 1:05, 1 user, load average: 0.23, 1.59, 3.00
Tasks: 118 total, 1 running, 117 sleeping, 0 stopped, 0 zombie
%Cpu0 : 1.0 us, 0.7 sy, 0.0 ni, 98.3 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
%Cpu1 : 1.3 us, 0.0 sy, 0.0 ni, 98.7 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
%Cpu2 : 0.7 us, 0.7 sy, 0.0 ni, 98.7 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
%Cpu3 : 10.7 us, 0.0 sy, 0.0 ni, 89.3 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem: 947732 total, 423340 used, 524392 free, 17988 buffers
KiB Swap: 2199544 total, 0 used, 2199544 free. 197936 cached Mem

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
824 pi 20 0 352344 165376 11316 S 15.5 17.4 26:22.03 java

1875 pi 20 0 5112 2228 1824 R 1.0 0.2 0:00.12 top

497 debian-+ 20 0 47736 6128 5080 S 0.3 0.6 0:11.72 transmission-da
822 pi 20 0 12908 2328 1752 S 0.3 0.2 0:05.17 wrapper

1446 root 20 0 0 0 0 S 0.3 0.0 0:00.36 kworker/2:0

1 root 20 0 5464 3880 2744 S 0.0 0.4 0:06.10 systemd
2 root 20 0 0 0 0 S 0.0 0.0 0:00.01 kthreadd
3 root 20 0 0 0 0 S 0.0 0.0 0:01.03 ksoftirqd/0
5 root 0 -20 0 0 0 S 0.0 0.0 0:00.00 kworker/0:0H

Subtickets

Change History (3)

comment:1 Changed 2 years ago by zzz

I have a RPi 2 (the 1-core, 256MB one). If I run apt-get update without stopping I2P first, the whole thing locks up. I also know the I/O to the SD card (and yes I have a class 10 card) is unbelievably slow. I also know there is swap space configured to /var/swap which is a file. So if it does start swapping it just makes more I/O to the SD card. I've tried to get a USB hard drive that will work with it so I can have real swap but every drive I try doesn't work.

I don't have any ideas what the problem is for you. CPU? I/O? some JVM bug? Some hardware or driver problem? I can only offer generic advice to try to lower the limits - either max memory (in wrapper.config), or max bandwidth (on /config in the console), or some of the limits on the snark configuration page.

I know I used to see all sorts of strange errors on the RPi that I never saw anywhere else. Most of that was with OpenJDK... Oracle 8 has been much better. Maybe it's too much to expect a $35 board to be reliable. Of course we shouldn't be able to lock it up from a Java program.

My best guess on your issue is the SD card I/O. But what do I know.

comment:2 Changed 2 years ago by 2121

I have similar issues with my RPi 3 - it turns out that the reserved memory of the kernel vm.min_free_kbytes drops below the value that it should be normally.
Especially when running backup with rsync from my device the effect is noticeable - the systems seems to freeze temporary - probably an OOM cannot be thrown out any more.
Running sysctl -p resolved this issue - i added it to the rc.local.
On my system i have vm.min_free_kbytes = 32768

comment:3 Changed 18 months ago by zzz

  • Resolution set to not our bug
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.