Opened 11 years ago

Closed 10 years ago

#2 closed enhancement (fixed)

Wrapper not restarting i2p on windows after a soft-restart.

Reported by: hottuna Owned by:
Priority: minor Milestone: 0.6.5
Component: router/wrapper Version:
Keywords: Cc:
Parent Tickets:

Description

Im running java 1.6.5 on a vista premium x64 box.

The only log-msg I get is
"jvm exit code 4"

Subtickets

Change History (8)

comment:1 Changed 11 years ago by anonymous

  • Milestone set to 0.6.2.0

comment:2 Changed 11 years ago by welterde

  • Component changed from router/update to router/wrapper

comment:3 Changed 11 years ago by cooltimes

Please find out what version of java VM you are running, and is it Sun Java?

Find this by going to command prompt and typing java -version

comment:4 Changed 11 years ago by cooltimes

Also, how exactly are you starting I2P? i2prouter.bat? i2p.exe? i2psvc.exe?

Finally, copy and paste your wrapper.config file into this ticket for review.

Thanks

comment:5 Changed 11 years ago by welterde

  • Milestone changed from 0.6.2.0 to 0.6.2.1

comment:6 Changed 11 years ago by welterde

  • Milestone changed from 0.6.3 to 0.6.4

comment:7 Changed 10 years ago by welterde

  • Milestone changed from 0.6.4 to 0.6.5

comment:8 Changed 10 years ago by zzz

  • Resolution set to fixed
  • Status changed from new to closed
  • Type changed from defect to enhancement

I suspect he was starting it without the wrapper.
I checked in a change to remove the "restart" button on the router console if the wrapper is not present. 0.6.5-4.

Note: See TracTickets for help on using tickets.